3

I need to install a tofrodos 1.17.3 for i386. I'm running Ubuntu 16.04.2 and I know that if I run sudo apt-get install tofrodos:i386 it will install version 1.17.3. However this will be in a script which possibly will be used much later and I need to fix the version, 1.17.3 and the 32 bit architecture, i386. Does anyone know how to do that?

I've already tried

sudo apt-get install tofrodos=1.17.3:i386
sudo apt-get install tofrodos:i386=1.17.3

and none of them worked.

Any help is appreciated.

  • use the software center or aptitude to get the full version name. usually somethin like 1.17.3-ubuntu# – ravery Jul 11 '17 at 20:35
2

Nobody can guarantee that the package in the repository will be a fixed version.

It is possible to hold an installed package from upgrading, but apt will always install an available version from the repos. Nobody keeps old versions there.

There actually may be two versions the initial one and an "upgrade" one.

But it is very unlikely that a package will be upgraded to some new major version in an LTS repository. Some minor fix may be released, but I don't think it can affect functionality.

The

sudo apt-get install tofrodos:i386=version

is the correct command. But there is no 1.17.3 version in the repos.

The correct version is 1.7.13+ds-2ubuntu1.

pilot6@Pilot6:~$apt-cache policy tofrodos
tofrodos:
  Installed: (none)
  Candidate: 1.7.13+ds-2ubuntu1
  Version table:
     1.7.13+ds-2ubuntu1 500
        500 http://ru.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

So the

sudo apt-get install tofrodos:i386=1.7.13+ds-2ubuntu1

should work.

It is the "initial" version for xenial. Even if the package is upgraded in xenial-updates the command will install this version.

0

If the package is available in the repositories you can install a specific version from a specific architecture of a package using this command:

sudo apt-get install package:i386=version

to see if your desired version is available to you, use:

apt-cache madison package-name

or

apt-cache policy package-name

the other option for your case is:

apt list -a i386 tofrodos

And it seems your desired package version does not exist in the repositories.

  • How can this work? – Pilot6 Jul 11 '17 at 20:34
  • How can not? is something wrong with the package? cause I think the command is wrong ... !? – Ravexina Jul 11 '17 at 20:35
  • Ubuntu repos have one version of a package for each release. So it makes no sense to specify a version. – Pilot6 Jul 11 '17 at 20:36
  • 1
    You sure? cause always a base version is available in the dist repository and the updates will be placed in the dist-updates so you should have at least one and in most cases two version, However as I can see the OP's command is wrong so I provide another command which I know works (If the package exists in repo). – Ravexina Jul 11 '17 at 20:38
  • Oh, you are correct. There are actually two versions. – Pilot6 Jul 11 '17 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.