7

How do I set LibreOffice to spellcheck in British English? When I set it to BE now, it doesn't spellcheck anything. I'm using the latest LibreOffice in Ubuntu 17.04.

9
  • How did you set it ?
    – Panther
    Jul 11 '17 at 15:32
  • Have you installed the hunspell-en-gb package? Jul 11 '17 at 15:39
  • 1
    @bodhi.zazen Options > Language Settings > Languages. Regarding your marking my question as duplicate, the dictionaries listed in the first answer are from 2012 and there are no British English dictionary extensions in the link that the last answer gave. The middle answer is what I already did.
    – Amolith
    Jul 11 '17 at 15:40
  • 1
    As your google is broken, dictionaries here - extensions.libreoffice.org/extensions/english-dictionaries . This is a duplicate as explained in the link I indicated, British dictionary is NOT included in the ubuntu package and must be downloaded fro libreoffice site. @GunnarHjalmarsson - As far as I know, libreoffice uses its own dictionaries and not hunspell
    – Panther
    Jul 11 '17 at 15:42
  • 1
    since this one has the updated answer now, I am voting to close the other one as a duplicate of this one
    – Zanna
    Jul 12 '17 at 16:02
12

The simplest way to enable British spell checking in LibreOffice on recent Ubuntu versions is to install the hunspell-en-gb package.

sudo apt install hunspell-en-gb

Not the answer you're looking for? Browse other questions tagged or ask your own question.