0

I'm having problems with my Wi-Fi. I can't turn it on. I looked at the network settings and airplane mode is on. I tried to turn it off, but every time that I close the window, the airplane mode is turned on again, and my Wi-Fi button will not turn on no matter what.

Here is the list of things that I have tried:

  1. restart the system.
  2. sudo rfkill unblock all.
  3. sudo service network-manager restart.
  4. I tried to look for Wi-Fi options in my BIOS, but there was no such thing.

And this is a report from my system. BTW I am new to Ubuntu.

```

########## wireless info START ##########

Report from: 11 Jul 2017 12:52 IRDT +0430

Booted last: 11 Jul 2017 00:00 IRDT +0430

Script from: 25 Mar 2017 07:04 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 16.04.2 LTS
Release:    16.04
Codename:   xenial

##### kernel ############################

Linux 4.8.0-58-generic #63~16.04.1-Ubuntu SMP Mon Jun 26 18:08:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

Ubuntu

##### lspci #############################

02:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    Subsystem: Foxconn International, Inc. T77H126.00 802.11bgn Wireless Half-size Mini PCIe Card [105b:e017]
    Kernel driver in use: ath9k

09:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
    Subsystem: Sony Corporation AR8151 v2.0 Gigabit Ethernet [104d:908a]
    Kernel driver in use: atl1c

##### lsusb #############################

 - Bus 002 Device 004: ID 046d:c52f Logitech, Inc. Unifying Receiver Bus
  - 002 Device 003: ID 0900:1001 Pinnacle Systems, Inc.  Bus 002 Device
  - 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002
  - Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device
  - 003: ID 064e:a21b Suyin Corp.  Bus 001 Device 002: ID 8087:0024 Intel
  - Corp. Integrated Rate Matching Hub Bus 001 Device 001: ID 1d6b:0002
  - Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

##### lsmod #############################

 - acer_wmi               20480  0 sparse_keymap          16384  1
 -  acer_wmi ath9k                 147456  0 ath9k_common           36864
 -  1 ath9k ath9k_hw              475136  2 ath9k,ath9k_common ath       
 -  32768  3 ath9k_hw,ath9k,ath9k_common mac80211              761856  1
 -  ath9k cfg80211              581632  4 mac80211,ath9k,ath,ath9k_common
 -  mxm_wmi                16384  1 nouveau video                  40960 
 -  3 sony_laptop,acer_wmi,nouveau wmi                    16384  3
 -  acer_wmi,mxm_wmi,nouveau

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

enp9s0    

 - Link encap:Ethernet  HWaddr <MAC 'enp9s0' [IF1]>  
 -            inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
 -            inet6 addr: fe80::5be9:42aa:e206:1e3e/64 Scope:Link
 -            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
 -            RX packets:27646 errors:0 dropped:0 overruns:0 frame:0
 -            TX packets:17012 errors:0 dropped:0 overruns:0 carrier:5
 -            collisions:0 txqueuelen:1000 
 -            RX bytes:38851631 (38.8 MB)  TX bytes:1442279 (1.4 MB)

lo        

 - Link encap:Local Loopback  
 -            inet addr:127.0.0.1  Mask:255.0.0.0
 -            inet6 addr: ::1/128 Scope:Host
 -            UP LOOPBACK RUNNING  MTU:65536  Metric:1
 -            RX packets:1379 errors:0 dropped:0 overruns:0 frame:0
 -            TX packets:1379 errors:0 dropped:0 overruns:0 carrier:0
 -            collisions:0 txqueuelen:1 
 -            RX bytes:110965 (110.9 KB)  TX bytes:110965 (110.9 KB)

wlp2s0    

 - Link encap:Ethernet  HWaddr <MAC 'wlp2s0' [IF2]>  
 -            BROADCAST MULTICAST  MTU:1500  Metric:1
 -            RX packets:0 errors:0 dropped:0 overruns:0 frame:0
 -            TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
 -            collisions:0 txqueuelen:1000 
 -            RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

>##### iwconfig ##########################

 - lo        no wireless extensions.

 -  enp9s0    no wireless extensions.

 -  wlp2s0    IEEE 802.11  ESSID:off/any  
             Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
             Retry short limit:7   RTS thr:off   Fragment thr:off
             Power Management:off

```

  • 1
    Your wireless is hard blocked. There may be a hardware switch or it is disabled in BIOS. If that is not the case sony_laptop snould be blacklisted. – Pilot6 Jul 11 '17 at 11:44
  • I found the fn+f1 key for hardware switch and it didnt help me, I also looked for it in Bios and there isnt anything related there, can u tell me with details how should I blacklist the sony _loptop snould?I am new to ubunto – salman rezaie Jul 12 '17 at 6:55
1

We see this in your loaded modules:

    acer_wmi               20480  0 sparse_keymap          16384  1
 -  acer_wmi ath9k                 147456  0 ath9k_common           36864
 -  1 ath9k ath9k_hw              475136  2 ath9k,ath9k_common ath       
 -  32768  3 ath9k_hw,ath9k,ath9k_common mac80211              761856  1
 -  ath9k cfg80211              581632  4 mac80211,ath9k,ath,ath9k_common
 -  mxm_wmi                16384  1 nouveau video                  40960 
 -  3 sony_laptop,acer_wmi,nouveau wmi                    16384  3
 -  acer_wmi,mxm_wmi,nouveau

I don't believe that your laptop is both an Acer and a Sony. Let's blacklist sony-laptop and see if you can now turn on the wireless:

sudo -i
echo "blacklist sony_laptop"  >>  /etc/modprobe.d/blacklist.conf
exit

Reboot and let us hear the result.

EDIT: Since you've found that the blacklist is not helpful, let's reverse it:

sudo gedit /etc/modprobe.d/blaclist.conf

Use nano or kate or leafpad if you don't have the text editor gedit. Change the last line from:

blacklist sony_laptop

To instead read:

blacklist acer_wmi

Proofread carefully, save and close the text editor.

Reboot. Is there any improvement?

  • I did this and then reboot my system doesnt help either my loptop is sony vaio ,shouldnt I blacklist the acer? – salman rezaie Jul 12 '17 at 6:44
  • Please see my edit above in a few moments. – chili555 Jul 12 '17 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.