1

I have a headless server that appears to have audio built into the motherboard which I need to configure.

I'm using spd-say to test it (also the reason I'm configuring audio). Currently, I don't get any audio output on any of the ports on the system.

I see what looks like two audio controllers:

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation C610/X99 series chipset HD Audio Controller (rev 05)
05:00.1 Audio device: NVIDIA Corporation GP104 High Definition Audio Controller (rev a1)
06:00.1 Audio device: NVIDIA Corporation GP104 High Definition Audio Controller (rev a1)

Following some other articles, I've listed the sinks using pacmd. I'm not familiar with this tool though. The output below looks somewhat different than on my laptop.

$ pacmd list-sinks
Welcome to PulseAudio! Use "help" for usage information.
>>> 1 sink(s) available.
  * index: 0
    name: <auto_null>
    driver: <module-null-sink.c>
    flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: RUNNING
    suspend cause: 
    priority: 1000
    volume: 0:  90% 1:  90%
            0: -2.75 dB 1: -2.75 dB
            balance 0.00
    base volume: 100%
                 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.21 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 0
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    used by: 4
    linked by: 4
    configured latency: 0.50 ms; range is 0.50 .. 2000.00 ms
    module: 11
    properties:
        device.description = "Dummy Output"
        device.class = "abstract"
        device.icon_name = "audio-card"

I don't know what devices I should be expecting to look for in /dev.

It's also not clear if there is an option in spd-say that I need to set to specify the output device.

Everything in the sound troubleshooting wiki seems to check out: https://help.ubuntu.com/community/SoundTroubleshooting

5
  • I can't remember the exact answer but when I configured a headless test setup for sound I sometimes had to enable permissions to access the audio group for that user - though according to the wiki this is a bad idea :). What program(s) to you want to receive audio from? – Wilf Jul 10 '17 at 23:12
  • I'm trying to get the command line speech synthesizer spd-say to work. I'll retry everything with sudo. – David Parks Jul 10 '17 at 23:27
  • 1
    Ah, yes, sudo aplay asoundfile.wav does work. Now to figure out how to get that to work without sudo. Adding the user to the audio group hasn't worked so far. – David Parks Jul 10 '17 at 23:54
  • @Wilf your comment was correct, it was a permission issue. I've opened another question for an issue with spd-say, but after adding the audio group to my user I can run aplay successfully. If you want to post that as an answer I'll accept it, and thank you for the help! – David Parks Jul 11 '17 at 0:26
  • Try alsamixer and see if the volume levels are shown, try setting the levels to a higher volume, then exit alsamixer, after which you can play something and expect some audio output. Place a screenshot in your question so we can see what's installed and working in alsamixer. Thank you – Geppettvs D'Constanzo Jul 11 '17 at 17:01
0

I believe a workaround to this issue is to add the user(s) to the audio group so they can access the audio outputs. This may have limitations such as you may still need a audio program to interface with ALSA, which when you are logged in a desktop environment is normally done via a pulseaudio server or similar.

Note this is not recommended on the wiki page. This may just be as it will then override other users and programs but it might be due to security implications as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.