I have exactly the following issue with Ubuntu 17.04 (Gnome shell and desktop installed)

When clicking on the Bookmark root or on one of the bookmarks below the mouse cursor gets stuck in "drag n drop" mode, blocking all keyboard entry and also mouse clicks for the the whole GUI (systemwide).


It`s a very old issue but without any concrete solution.

And happen not only in nautilus, others applications like kid3, KDE Connect, Kdenlive, Notes and others are affected. In many places of these applications a simple click stuck in "drag & drop" mode, is impossible to work with this problem, is very annoying.

Any idea or solution is welcome.

  • any relevant error message when running sudo journalctl -f ? Aug 23, 2017 at 14:32
  • Is it specific to Gnome? I'm asking because I can't reproduce it with Nautilus + i3, so either it was fixed, or it's specific to DE. Nautilus version is 3.24.2.
    – Hi-Angel
    Aug 25, 2017 at 19:36
  • Same problem here on 17.10. Killing nautilus did the trick.
    – wout
    Apr 3, 2018 at 8:23

2 Answers 2


For me, opening a terminal window and running pkill nautilus fixes it temporarily.

(But I don't know how to prevent the problem from occurring in the first place.)

  • 1
    Seems like one shouldn't drag items on the desktop. At least in my situation, this always causes the bug. Apr 11, 2018 at 21:19
  • 1
    Worked a treat !
    – user72056
    Sep 20, 2018 at 8:57
  • bloody annoying though Apr 16, 2019 at 0:24
  • I have not experienced this problem with the latest version of Ubuntu yet. So hopefully it's fixed now.
    – jonahe
    Apr 16, 2019 at 9:25
  • This did not fix the issue for me. May 20, 2019 at 9:12

I have experienced this sticky drag-and-drop bug over many Ubuntu versions, currently 20.04, but it seems to be very old (see launchpad). If you have a touchscreen or tablet it is very likely to be involved in the bug. If so, you should be able to temporarily fix by hitting ESC to get your mouse pointer back, then sometimes, just using your touchscreen (or whatever is involved, e.g. tablet, etc) instead of your mouse to click the offending feature clears the problem (until the next time).

Sometimes it doesn't. Then, open a terminal with CTRL+ALT+T, then type xinput at a command line to find the id of your touchscreen/tablet. Then, if it's 12 for example, type:

xinput --disable 12
xinput --enable 12

If that doesn't work, try using your mouse between the disable and enable commands. If it's not obvious which device ID is which, try a process of elimination. For example on my Lenovo Yoga 3 Pro laptop:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Synaptics TM2714-001                      id=11   [slave  pointer  (2)]
⎜   ↳ ATML1000:00 03EB:8A10                     id=12   [slave  pointer  (2)]
⎜   ↳ PixArt USB Optical Mouse                  id=14   [slave  pointer  (2)]
⎣ ...

Most people notice the bug when every click on a nautilus bookmark puts the system into drag-and-drop mode. For me, another repeatable symptom affects LibreOffice Calc. Once the bug has been triggered, if you click-select a worksheet tab or drag-select a set of cells then release the mouse, it also becomes stuck in drag-and-drop mode, and (strangely) draws a thick border around the selection, which you cannot undo or reformat.

  • This worked for me on Ubuntu 20.04.3 on my Dell XPS-13. Thank you!
    – mwalth
    Jan 27, 2022 at 18:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.