2

I have a disk, that has only one primary partition and that I want to be mount with permissions of the user for the contained files.

The mount point has the following permissions:

drwxr-xr-x 2 myself myself 4096 Jul 10 11:37 hdd4p1

The /etc/fstab contains the following entry:

/dev/sdd1   /home/myself/hdd4p1   ext4    rw,suid,dev,exec,auto,user,users,async  0   2

But when I mount it with:

mount hdd4p1

It changes the ownership of the mount point to root:

drwxr-xr-x 2 root root 4096 Jul 10 12:31 hdd4p1/

I have also tried default mount options and mounting with sudo, but it also changed the ownership to root.

1

I myself had attemped this. And all you have to do is use the sudo chown <user>:<group> -R /your/mountpoint.If you would to mount to FAT32 filesystem, then you would need to change your /etc/fstab file.

| improve this answer | |
  • I recommend making the stackexchange account next time. – Sławek Śpiewak Jul 10 '17 at 11:21
  • I tried changing first the ownership recursively, but it did not help. – user3174454 Jul 10 '17 at 11:27
  • Did you mount the filesystem as readonly? That could be a problem. Also notice the sudo before the command. – Sławek Śpiewak Jul 10 '17 at 11:33
  • If you think somebody solved the question, please click the tick below number of votes. (do not accidentally downvote the answer). – Sławek Śpiewak Jul 12 '17 at 11:07
  • Sorry it's sudo chown -R <user>:<group> /your/mountpoint my bad. – Sławek Śpiewak Jul 13 '17 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.