210

The system crash dialog is annoying me, how can I turn it off? I'd also like to know how to turn it back on just in case I need it to report a problem.

  • 4
    since this seems to effect numerous people, is it a bug with apport itself? – Thufir Nov 15 '14 at 0:04
  • 1
    Not sure but I also think the crash dump may contain full text files for ex. so if you have sensitive data on it, better keep it disabled. I think, every time a crash happens and that pops up, we should be clearly informed that a crash dump of like 200MB will be uploaded and it will contain data you were editing on the application. I finally found something that I dislike on ubuntu :(, never thought this day would come... – Aquarius Power Mar 22 '15 at 23:45
  • Please follow the instructions from the official Apport article in the Ubuntu wiki. – der_michael Oct 14 '16 at 5:57
251

As of Ubuntu 16.04 systemd apport does not seem to honor its config file

The systemd commands to enable / disable apport are:

Disable

sudo systemctl disable apport.service

If that does not work, you would then need to mask the service

systemctl mask apport.service

To reenable

systemctl unmask apport.service # if you masked it
sudo systemctl enable apport.service

Previous versions of Ubuntu:

You need to edit /etc/default/apport. The following changes will prevent Apport from starting at boot:


Graphical: Open a terminal with (CTRL+ALT+T) and type this:

sudo -i gedit /etc/default/apport

and then push ENTER. You password is being typed, but will not display as dots.

or

Command line:

sudo nano /etc/default/apport

A file editor is now open. Change enabled from "0" to a "1" so it looks like this:

enabled=1    

To turn it off make it:

enabled=0

Now save your changes and close the file editor. Apport will now no longer start at boot. If you want to turn it off immediately without rebooting, run sudo service apport stop.

You can also use sudo service apport stop without modifying /etc/default/apport to turn it off temporarily.

See also:

  • 1
    Isn't it the case that "service apport stop" will stop it for the present, and setting enabled=0 is what turns it off at boot? – Silvio Levy Mar 17 '15 at 7:26
  • @SilvioLevy yes, that's correct. I've updated the answer to reflect this. – dr. Sybren Jun 18 '15 at 9:03
  • should systemctl be used now since the switch to systemd from upstart? – MattSturgeon Mar 13 '16 at 22:35
36
  • Click on ubuntu icon, search for "System settings"
  • Select Privacy > Diagnostics tab
  • Unlock
  • Tick "Send error reports to Canonical"

Ubuntu 12.04 > Privacy > Diagnostics tab > Send error reports to Canonical

  • 12
    This didn't seem to do anything for me, still getting system error pop ups. – xamox Oct 11 '12 at 18:53
  • I had this checked, and it still wasn't sending error reports. Looks like it has to be enabled from the command line. – colan Jan 24 '14 at 21:51
  • 1
    btw, it didnt change /etc/default/apport – Aquarius Power Mar 22 '15 at 23:16
32
sudo service apport stop ; sudo sed -ibak -e s/^enabled\=1$/enabled\=0/ /etc/default/apport ; sudo mv /etc/default/apportbak ~

The above script should stop apport, then take a backup of its configuration file, disable apport on boot, and lastly moves the backup to your home directory.

  • 1
    Thanks! Out of all three of the answers, only this one worked for my friend when we overwrote Ubuntu onto his Chromebook! – Pip Sep 6 '14 at 23:52
12

On newer versions of ubuntu (15.04+)

To stop the service:

systemctl stop apport.service

To disable the service at startup:

sudo systemctl disable apport.service

To check the status of the service:

systemctl status apport.service

Finally, you can also prevent the startup of a systemd service by masking it. The service will not be able to start (even manually) unless unmasked.

systemctl mask apport.service

This should create symlink from /etc/systemd/system/apport.service to /dev/null. fedoraproject.org

  • It doesn't say which ubuntu rebase if I'm not mistaken. systemctl was introduced long after apport. – der_michael Oct 14 '16 at 5:54
  • @der_michael Yes, this is a newer answer for newer versions of ubuntu which use systemd. – mchid Oct 16 '16 at 4:50
4

Don't disable apport. One of these days, you might have a sequence of crashes and never know it except for system bad behavior or some application-specific symptom.

The /var/crash directory is there to record any mishap. You might need it some day.

Suggested procedure:

  • Create a new folder E.g. $HOME/crash and copy all of the existing crash reports to it.
  • sudo rm /var/crash/*
  • sudo reboot

The repetitive crash pop-up behavior should now be gone. Also, the crash reports that you saved might be valuable in reporting a bug to launchpad.

2

Since there's a bug in apport that breaks standard unix command line debugging, and this bug has been known since 2007 (I'm going to buy it a cake when it turns 10) (see https://bugs.launchpad.net/ubuntu/+source/apport/+bug/160999) turning it off is far and away the best thing to do if you are trying to fix your own code.

0

Why not just remove it entirely?

Version 16.04 LTS

sudo apt-get update
sudo apt-get remove apport
sudo rm /etc/cron.daily/apport

Also, might want to check this out:

Removing popularity-contest without trashing the system?

New to 18.04:

How to Opt Out of System Information Reports

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.