0

I recently (two weeks ago) installed Chromium in Ubuntu 14.04 LTS using software center. I normally use MATE desktop, installed alongside the default Unity desktop.

After I launch Chromium, the browser stays open for few seconds and then closes.

There was an update few days ago that I hoped would solve the issue, however it did not.

I tried to launch the browser from console. Below is the output I got:

$ chromium-browser
Using PPAPI flash.
 --ppapi-flash-path=/usr/lib/adobe-flashplugin/libpepflashplayer.so --ppapi-flash-version=
Received signal 11 SEGV_MAPERR 000000000010
#0 0x7fa588ef0d47 base::debug::StackTrace::StackTrace()
#1 0x7fa588ef1133 <unknown>
#2 0x7fa588bfe330 <unknown>
#3 0x55cbaeef49f8 <unknown>
#4 0x55cbaeef5fb1 <unknown>
#5 0x55cbaeef6633 <unknown>
#6 0x55cbaeef6bc7 <unknown>
#7 0x7fa588f65b91 <unknown>
#8 0x7fa588ef2269 base::debug::TaskAnnotator::RunTask()
#9 0x7fa588f19040 base::MessageLoop::RunTask()
#10 0x7fa588f1a97d base::MessageLoop::DeferOrRunPendingTask()
#11 0x7fa588f1b79d <unknown>
#12 0x7fa588f1c250 base::MessagePumpLibevent::Run()
#13 0x7fa588f18422 base::MessageLoop::RunHandler()
#14 0x7fa588f40df8 base::RunLoop::Run()
#15 0x7fa588f6ad56 base::Thread::ThreadMain()
#16 0x7fa588f65a96 <unknown>
#17 0x7fa588bf6184 start_thread
#18 0x7fa57f045ffd clone
  r8: 0000000000000000  r9: 0000000000000003 r10: 00007fa511ff9d18 r11: 00007fa57f0d2110
 r12: 00007fa511ff9fe0 r13: 0000000000000008 r14: 0000000000000008 r15: 00007fa511ff9fe0
  di: 0000000000000000  si: 00007fa511ff9fe0  bp: 0000000000000000  bx: 00007fa511ffa0f0
  dx: 00007fa57fb313d8  ax: 00007fa57fb313d8  cx: 0000000000000000  sp: 00007fa511ff9f90
  ip: 000055cbaeef49f8 efl: 0000000000010206 cgf: 0000000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000010
[end of stack trace]
Calling _exit(1). Core file will not be generated.
1

This looks awfully similar to a problem mentioned for 16.04. Does it work if you launch Chromium via chromium-browser --disable-extensions?

| improve this answer | |
  • It works, but honestly I do not know why, since I did not install any extension. The only change I made is described at the following askubuntu answer: askubuntu.com/a/908074/467407 After that I could not run Chromium any more. – Asarluhi Jul 9 '17 at 12:35
  • 1
    You enabled the media router extension? It appears to be at the heart of the problem/bug; several answers, such as this one, recommend disabling it. – Turtle Jul 9 '17 at 13:05
  • I disabled media router extension and the problem seems solved. However with media router disabled it is not possible to cast videos to Chromecast. – Asarluhi Jul 9 '17 at 14:10
  • 1
    Test packages available at bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1702407 should resolve until the fix hits main. – Trent Nelson Jul 9 '17 at 14:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.