0

A day ago I disabled Chromium extensions via chromium-browser --disable-extensions, as advised in many answers to this problem.

After that I successfully re-enabled them with chromium-browser --enable-extensions, which opens Chromium from the terminal.

However, whenever I start Chromium from Unity Launcher now, it opens with extensions disabled. Could anyone explain to me how I can re-enable them permanently for sessions initiated from the Launcher?

1

--disable-extensions should only apply to the session you launched with that parameter. It does not change settings. Are you sure you did not do anything else, like delete/rename your session directory as well?

See my post here for a work around and test packages for the original crash issue.

| improve this answer | |
  • I think I'm getting closer: After purging Chromium, when searching for "Chromium" in dash, an entry was still found, however labelled "Signal Private Messenger - Chrome Web Store - Chromium", but with the standard Chromium icon. Even when the 'proper' Chromium is installed, Unity still points at that weird entry. Do you happen to know how I can tell Unity to point at the proper Chromium? – Turtle Jul 9 '17 at 15:20
  • Thanks again for the hint in the first paragraph; that clarified that Chromium itself was not the problem. – Turtle Jul 9 '17 at 15:55
0

I would find the .desktop file and enable the Exec command to include the desired setting --enable-extensions that way the setting is parsed even when you launch it from unity or gnome.

| improve this answer | |
  • Thanks, but this smells a bit like a workaround, doesn't it? I mean, Chromium used to launch with extensions by default, without me having meddled with the (so far entirely empty) .desktop file before. – Turtle Jul 9 '17 at 11:57
0

I figured it out: When dealing with the current Chromium problem mentioned above, I must have accidentally created a file ~/.local/share/applications/chromium-browser.desktop. Whether Chromium was installed or not, Unity would point to that file only. I presume said desktop file must have stored the info to disable extensions. Deleting it solved the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.