I have Dell Inspiron 5567 laptop (i-7, 8GB) with Windows-10 OS installed on it. I am trying to install ubuntu 16.04 as a dual boot OS on Windows10. I have disabled fast boot and secure boot options also. I am facing this error while installing Ubuntu 16.04:

grub-efi-amd64-signed failed to install into /target/. Without GRUB boot loader, the installed system will not boot

The target partition is /dev/sda1.

I have created three partitions:

20GB-ext4- Root mounted
18.9GB-ext4- /home
4GB Swap area

Launchpad link for the log files: https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1703167

Pastebin link for boot-repair: https://pastebin.com/raw/u4LSP0V4

Output of sudo fdisk -l:

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: F87D48DF-F3FF-429E-8F0B-558F81712A60

Device          Start        End    Sectors   Size Type
/dev/sda1        2048    1026047    1024000   500M EFI System
/dev/sda2     1026048    1288191     262144   128M Microsoft reserved
/dev/sda3     1288192 1843265535 1841977344 878.3G Microsoft basic data
/dev/sda4  1927151616 1928073215     921600   450M Windows recovery environment
/dev/sda5  1928073216 1951281151   23207936  11.1G Windows recovery environment
/dev/sda6  1951281152 1953523711    2242560   1.1G Windows recovery environment
/dev/sda7  1843265536 1851078655    7813120   3.7G Linux swap
/dev/sda8  1851078656 1890140159   39061504  18.6G Linux filesystem
/dev/sda9  1890140160 1927151615   37011456  17.7G Linux filesystem

Partition table entries are not in disk order.

Output of sudo parted -l:

Model: ATA TOSHIBA MQ01ABD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  525MB   524MB   fat32           EFI system partition          boot, esp
 2      525MB   660MB   134MB                   Microsoft reserved partition  msftres
 3      660MB   944GB   943GB   ntfs            Basic data partition          msftdata
 7      944GB   948GB   4000MB  linux-swap(v1)
 8      948GB   968GB   20.0GB  ext4
 9      968GB   987GB   18.9GB  ext4
 4      987GB   987GB   472MB   ntfs                                          hidden, diag
 5      987GB   999GB   11.9GB  ntfs                                          hidden, diag
 6      999GB   1000GB  1148MB  ntfs                                          hidden, diag

Model: SRT USB (scsi)
Disk /dev/sdb: 32.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
1      1049kB  32.5GB  32.5GB  primary  fat32        boot, lba

Please guide me how to resolve this problem.

marked as duplicate by karel, Parto, MadMike, Fabby, b_laoshi Oct 8 at 3:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @RodSmith why is this a duplicate? The target you chose has very few helpful answers and the only one that is significantly upvoted assumes there was no EFI partition,. The OP here has an EFI partition so I don't see how it could be the same problem. What am I missing? – terdon Jul 9 '17 at 15:16
  • Finally it worked @terdon. Have posted it as an answer. – Benedict Florance Jul 12 '17 at 12:46

The EFI System Partition was corrupt. I rectified this error with the following steps:

On Windows, I used DISKPART to assign the EFI System partition a letter. Fired up DISKPART, and typed LIST DISK to find the disk, followed by SELECT DISK <N> (where is the drive number). Followed the same steps to find the proper partition (i.e. LIST PARTITION followed by SELECT PARTITION <N>), and then simply typed ASSIGN LETTER = X to have Windows mount the partition to letter X.

Then opened CMD with administrative access. Ran CHKDSK X: /f /r

Then, I tried installing Ubuntu once again, and it installed successfully!


I have seen this with many computers, it is not the grub install that actually fails but the update-grub that makes the first config file that fails.
the problem is that the if/then statement in 30_uefi-firmware errors.

the easiest fix is after it error, choose the command line prompt at the bottom of the installer menu. and use nano to edit the file /etc/grub.d/30_uefi-firmware.
I have changed mine to read:

gettext_printf "Adding boot menu entry for EFI firmware configuration\n" >&2
cat << EOF
menuentry 'uefi-firmware' {

after editing rerun install grub.
note: on some systems the print command needs to be commented out temporarily for the installer

  • I don't get any command line prompt at the bottom of the installer menu? – Benedict Florance Jul 9 '17 at 6:13
  • finish the install with out grub, when booting you should get a grub command line. or use the grub from the installer disk ( press "c" to get the command line). follow these directions for booting askubuntu.com/a/931327/694267. you will have to change the drive designations to match your installation. looks like sda8 is root partition, so linux (hd0,8)/vmlinuz root=/dev/sda8 – ravery Jul 9 '17 at 6:17
  • I'm getting a screen upon booting like the link you've mentioned. Now what should I do. Follow the instructions according to that question? When should I change /etc/grub.d/30_uefi-firmware – Benedict Florance Jul 9 '17 at 6:24
  • yes follow those directions, substitute in (hd0,8) and /dev/sda8 for drive desegnations. change /etc/grub.d/30_uefi-firmware before running update-grub – ravery Jul 9 '17 at 6:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.