Got a Logitech X300, it wont connect via A2DP. I have done few things in Pulse and /etc/bluetooth/audio.conf to not avail. Please help. I just want things to work and get on with my life.

This is one of the post I tried to follow Bluetooth speaker no sound in Ubuntu 16.04

It has made things worse and I cannot even get my speaker to stay connected for more than a second.

I tried purging all the things, but I do not even know how to reset drivers. I am a general computer user that wants a solid alternative to windows, but can't get shit like a bluetooth speaker to work.

  • 1
    Assuming you can undo whatever you've done??, what you needed to do is on this page under "Workaround 2: disable pulseaudio's bluetooth in gdm". Note that that file (/var/lib/gdm3/.config/pulse/default.pa) doesn't exist in Ubuntu so you'd need to create it first, then populate as shown. Probably a reboot is also needed.
    – doug
    Jul 9 '17 at 4:25
  • 1
    Sorry, forgot link... wiki.debian.org/BluetoothUser/a2dp Also I mention in LP bug on, comment 13 - bugs.launchpad.net/ubuntu-gnome/+bug/1489651
    – doug
    Jul 9 '17 at 4:32
  • 1
    Thank you, I messed with the comment on the bug and did what Tom said in his comment. Then I followed the Debian wiki and then it started working. Thank you. If you are able reply with your comment so I can mark it as the answer and help your askubuntu cred. Jul 9 '17 at 17:04
  • This helped me to restore the a2dp at ubuntu 18.04 mate: see my comment at askubuntu.com/questions/1177536/not-possible-to-connect-to-a2dp Apr 14 at 16:41

I had (I guess...) the exact same problem as Richard Grant using a headset Creative WP-350. It used to work fine on Ubuntu 16.04 and then the problem occurs when I switched to Ubuntu GNOME 17.04. I was able to connect and pair the headset, and use it with "HFP/HSP" audio profile. When trying to switch to "A2DP" profile, it didn't work and indicate "Failed to change profile to a2dp_sink".

As doug indicated in his comment, the fix is to disable pulseaudio's bluetooth in gdm. Actually I don't understand the reason why pulseaudio's BT is enabled in Gnome Display Manager but there might be a good reason for that... if anyone can clarify this I'd like to understand.

So the fix is pretty easy, based on this link provided by doug, here is what I did:

  1. Open a terminal window and type (This first point is user-dependant, the main info follow...)

    gksudo nautilus
  2. then navigate to /var/lib/gdm3/.config/pulse

  3. Open default.pa if it exists or create it (I had to), as a regular text file.
  4. Add the following lines in the file default.pa

    #!/usr/bin/pulseaudio -nF
    # load system wide configuration
    .include /etc/pulse/default.pa
    ### unload driver modules for Bluetooth hardware
    .ifexists module-bluetooth-policy.so
      unload-module module-bluetooth-policy
    .ifexists module-bluetooth-discover.so
      unload-module module-bluetooth-discover
  5. Save the file, close the Terminal window and reboot.

  • This did it for me! Bluetooth speakers were working fine under the out-of-the-box Ubuntu 17.04, and then would disconnect/get incorrectly configured once I switched from Unity to Gnome. The above steps let them connect normally again. Aug 29 '17 at 18:00
  • Confirmed fix also. GDM and bluetooth don't play nice with each other.
    – Kevin
    Sep 2 '17 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.