8

I am trying to connect to a L2TP over IPsec VPN I installed network-manager-l2tp and this repository : ppa:nm-l2tp/network-manager-l2tp and when I'm trying to add the connection from Network Connections I get this error:

Could not load editor VPN plugin for 'org.freedesktop.NetworkManager.l2tp' (missing plugin file "/usr/lib/x86_64-linux-gnu/NetworkManager/libnm-vpn-plugin-l2tp-editor.so").

How can I install the plugin?

  • 2
    What happens if you install network-manager-l2tp-gnome? – Kaz Wolfe Jul 8 '17 at 21:33
  • Well, it works :D – sticsk Jul 8 '17 at 21:35
  • Alright, answer added for sake of completeness. Glad I could help! – Kaz Wolfe Jul 8 '17 at 21:37
  • For a command-line only approach see... askubuntu.com/a/983971/201083 – kervin Dec 8 '17 at 0:26
9

This appears to be because you just installed the command-line side of NetworkManager's L2TP support.

In order to use the GUI to configure L2TP VPNs as well, you will need to install the network-manager-l2tp-gnome package like so:

sudo apt install network-manager-l2tp-gnome

Following this, a restart of nm-applet may be necessary to make NetworkManager see the change. In order to do this, just run the following:

killall nm-applet
nm-applet &
disown

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.