2

I cannot boot ubuntu correctly since last kernel update. uname -r gives 4.4.0-83-generic

After booting, I get following message:

lvmetad is not active yet, using direct activation during sysinit
/dev/mapper/ubuntu--vg-root: clean, 1014488/15097856 files, 29730400/60376064 blocks

Basycally, I have the very same error than Lvmetad is not active yet except no login screen is shown: it freezes here. Waiting very long doesn't change anything.

I tried the following solutions by using tty2:

  • uselvmetad = 0 change in /etc/lvm/lvm.conf ==> no change
  • lvmetad is blocking boot process except when I wait very long, nothing happen. My /proc/swaps file was empty like OP. After doing his solution, here's the cat of it: /dev/dm-1 partition 8302588 0 -1 ==> still no booting. Note that update-initramfs -k all -c worked properly for the last 3 installed kernels, bugged for the previous ones (that I removed with apt-get autoremove not sure why they appear but this seems unrelated to my issue)
  • I enabled and started the lvm2-lvmetad.service and .socket such as explained here https://unix.stackexchange.com/questions/199164/error-run-lvm-lvmetad-socket-connect-failed-no-such-file-or-directory-but .
  • I did try some of the solution from a live ubuntu USB stick
  • I did try some of the solution from recovery-mode: at some points it crashes and I have no time to read the error messages
  • I did try to return to previous kernells: samely unabootable.

I cannot copy and paste, but I can say that:

>> sudo lvdisplay

/dev/ubuntu-vg/root & /dev/ubuntu-vg/swap_1 appear correctly

>> sudo blkid

/dev/mapper/ubuntu--vg-root with ext4 and /dev/mapper/ubuntu--vg-swap_1 with swap type appear correctly and UUID of the latter corresponds under cat /etc/initramfs-tools/conf.d/resume

 >>cat /etc/fstab
 /dev/mapper/ubuntu--vg-root / ext4 errors=remount-ro 0 1
 UUID=XXX /boot ext2 defaults 0 2#the correct UUID appears here, just too long to copy
 #/dev/mapper/ubuntu--vg-swap_1 none swap swap 0 0#this was commented out manually
 /dev/mapper/ubuntu--vg-swap_1 swap swap defaults 0 0#this was added manually

I tried alternatively to use /dev/ubuntu-vg/root and ./swap as well as use the UUIDs instead: no change.

I believe the problem comes from displaying, so here is a sample of lspci

  >>lspci -v
  XXX [AMD/ATI] Tonga PRO [Radeon R9 285/380] (rev f1)
  Kernel driver in use: amdgpu
  Kernel modules: amdgpu

Down-voting because already asked on the forum? Please be constructive and comment with the link to the solution I did not already try. thank you.

EDIT: I tried to update my grub, but I had a lot of errors due to disabled lvmetad. I rechanged lvmetad to 1, then did update grub with no problem. Now when I reboot, only the second line appears, not the first, e.g.:

 /dev/mapper/ubuntu--vg-root: clean, 1014488/15097856 files, 29730400/60376064 blocks

I guess it's normal as now lvmetad is reactivated.

EDIT2: It seems I do have a problem with either amdgpu-pro or xorg. I cannot display correctly, even with live-USB (forgot to mention that). Readding tags

0

The problem is really due to AMDGPU-PRO. My previous version was 16.30. It seems it doesn't work on Ubuntu 16.04.2 LTS anymore, you need to go to 17.10

Solution:

  • go to http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx from another computer
  • Download on the other computer the driver (version 17.10)
  • you can unpack it as explained on the amd website
  • copy to a usb stick
  • start in normal mode your faulty computer, go to tty (ctrl + alt + F1)
  • mount the usb stick (note your usb might be elsewhere than on /dev/dbb1)

    mkdir /media/usb
    mount /dev/dbb1 /media/usb
    cp media/usb/amdgpu....tar.xz /tmp
    
  • after copying to /tmp, first uninstall the previous version amdgpu-pro-uninstall

  • then follow amd's website install procedure as usual.
  • after rebooting, I had problems with login in. you need to check who owns .Xauthority: ls -lA. If it is root:root instead of your username, then do sudo chown username:username .Xauthority (with username being your real username ;) )

I still have weird issues around, but at least I can use my computer correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.