3

Currently I have installed Manjaro, but have access to GRUB before loading the OS, my USB is recognized, but it won't boot from it, even if I manually select it.

I've tried using different programs on another Windows machine to make the USB bootable with Windows and tried 4 ISOs using different partition types (MBR/GPT) and it still won't boot from it. I thought of fully resetting the BIOS, but I can't do it since my laptop (Innjoo Leapbook M100) doesn't have a CMOS battery and frankly, I don't think it's necessary since if I put Manjaro on a USB again, I can fully boot and install it, so it works fine.

Things I've tried to make it boot from the USB:

  • Format the drive in FAT32 and put a W7 on it. It recognizes it, but it still won't boot from it.
  • I tried the "GPT partition scheme for UEFI" and the format for my W10 .iso auto-changes to FAT32, but the same thing happens as in W7.
  • I've also tried Unetbootin, Universal USB Installer and Windows 7 USB DVD Download Tool.
  • I've tried to put W10 and W7 using Rufus as well.
  • If I use NTFS format for W10 using Rufus, it doesn't recognize it, therefor it doesn't boot from it.
  • I tried putting the W10 using DD on Manjaro. It still wouldn't recognize it.
  • The last thing I tried is putting the W10 on a USB with the official W10 tool from Microsoft that downloads and puts it on the USB. It recognizes it, but it still won't boot so I can install it.

Additional information:

  • When I was installing Manjaro, I had to use Rufus with the DD Image option.
  • My BIOS has only 3 tabs: "Main", "Boot" and "Save and Exit" (Aptio Setup Utility - American Megatrends). There is no way to set up things like "Legacy mode", nor is the "Fast boot" option enabled.

I found this, but I don't know how to do it for a Windows. How do I do that (using GRUB 2.02)?

2

From grub type: ls (that is an L) to list your devices.

Assuming that your USB shows up as (hd1) and there is only 1 partition type:
chainloader (hd1,1)+1
boot

20
  • When I type ls, I get (hd0) (hd0,msdos1) (hd1) (hd1,gpt3) (hd1,gpt2) (hd1,gpt1) (hd2) (hd3). I'm assuming (hd0,msdos1) is my USB containing the W10. Would this be correct chainloader (hd0,msdos1)+1 and then boot ? I'd try it myself, but I don't want to mess it up since I not very good with Linux, let alone GRUB, I figured it'd be safer to ask first. – DoombringerBG Jul 7 '17 at 18:51
  • yes, that would be the way – ravery Jul 7 '17 at 18:52
  • OK. Will try that. Should I still install vmlinuz and initrd somehow or do they come installed? If I only put chainloader (hd0,msdos1)+1 I get an error saying "invalid EFI file path". – DoombringerBG Jul 7 '17 at 18:55
  • 1
    On the USB? If, so, then Yes. It's in "/efi/boot/bootia32.efi". I was thinking, am I supposed to put "chainloader (hd0,msdos1)+1 root=/efi/boot"? or "chainloader (hd0,msdos1)+1 root=/dev/sda/sda1/efi/boot"? Also, there's a file called "bootmgr.efi" in the main folder outside of everything on the USB. – DoombringerBG Jul 7 '17 at 19:12
  • 1
    try chainloader (hd0,1)/efi/boot/bootx64.efi (note: it may be case sensitive) – ravery Jul 7 '17 at 20:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.