I am attempting to install Ubuntu 17.04 on my Dell XPS 15. I have disabled secure boot and hibernation mode in Windows. When I run the Ubuntu installer from a USB drive, it skips asking me what "installation type" I would prefer, and brings me right to the manual partitioning option. The problem is that nothing shows up, and clicking on the "+" and "change" buttons causes the installer to freeze: Manual Partitioning. According to GParted, Ubuntu is not recognizing my computer's SSD, merely the USB drive that I am using to boot it: GParted in "Try Ubuntu" mode. Is there a fixable bug that could be causing Ubuntu to fail to recognize the SSD?

  • In your BIOS, is the SSD setup as RAID, or something else?
    – heynnema
    Jul 7, 2017 at 18:35
  • @heynnema RAID is enabled at the moment, yes. Jul 7, 2017 at 19:13

1 Answer 1


Make sure to have a backup of your important Windows files!

You've got a single SSD set up in RAID mode, and the Ubuntu installer won't recognize your SSD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot. Looking at this article https://samnicholls.net/2016/01/14/how-to-switch-sata-raid-to-ahci-windows-10-xps-13/ will show you how to make the change without having to reinstall Windows.

Boot to Windows with your current SATA controller configuration
Open Device Manager
Expand Storage Controllers and identify the Intel SATA RAID Controller
View properties of the identified controller
On the Driver tab, click the Update driver… button
Browse my computer…, Let me pick…
Uncheck Show compatible hardware
Select Microsoft as manufacturer
Select Microsoft Storage Spaces Controller as model
Accept that Windows cannot confirm that this driver is compatible
Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

  • 1
    Could I just switch from RST to AHCi, install ubuntu and then change between RST and AHCI to determine which system I want to boot into? Maybe this would be bad for the system/hardware/windows, I don't know. Thoughts?
    – edencorbin
    Nov 7, 2018 at 0:11
  • @edencorbin see my other answer here.
    – heynnema
    Nov 7, 2018 at 0:18
  • thanks, I went for it and it worked well, also found this helpful: medium.com/@petragospodneti/…. Just a few boots in but seems to be working great! Running flex-5-1570
    – edencorbin
    Nov 7, 2018 at 6:22
  • This helped with my Lenovo IdeaPad 330S-15IKB that was set up with RST for Intel Optane and an HDD.
    – Andrew
    Nov 18, 2018 at 19:07
  • This put my computer in an automatic repair loop and I had to reset. Do not follow these instructions. Sep 28, 2019 at 19:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.