I extracted the source, opened the terminal, moved to source directory and ran the following command:

sudo ./configure

Error: command not found! what is wrong with it?

  • 1
    What command was not found? Have you yet ... sudo apt-get install build-essential? – user8290 Jan 6 '12 at 13:15
  • i'm new in Linux, whats first steps to compile a source? what should i do whit apt-get? – user seven Jan 6 '12 at 13:16
  • 1
    The basic building blocks are in the package, build-essential. If you install it, then the commands that configure uses will be available. Then, the configure command will let you know what other programs or libraries may be required to build the program. – user8290 Jan 6 '12 at 13:21
  • Sounds like there isn't a configure script. Not every package uses configure, make, make install. What package is this? – tumbleweed Jan 6 '12 at 13:42
  • i used sudo apt-get install build-essential and it downloaded , but still the same error – user seven Jan 6 '12 at 13:51

Firstly, don't do sudo su. You can build as your user.

I assume you are building bluefish from SVN, and thus don't have a configure script. You can create it by running ./autogen.sh, as described here: http://bluefish.openoffice.nl/development.html

svn co https://bluefish.svn.sourceforge.net/svnroot/bluefish/trunk/bluefish
cd bluefish
sudo make install
  • thanks i just used bluefish as an example to compile coz i could not compile anything, now i tried another program "gwget", and took screen shot ,i gives another error – user seven Jan 7 '12 at 8:02
  • OK, now it looks like you don't have a C compiler installed. Install build-essential, and everything else gwget requires (see it's README / INSTALL file) – tumbleweed Jan 7 '12 at 8:30

First you should extract the contents of the *.tar.gz file in a directory. Read instructions in the INSTALL file, which gives you detailed instructions how to do it.

For "some" software you want to install the following method works: 1. extract the archive into a directory 2. cd to that directory 3. ./configure (add "--prefix=/usr" if you want to install it in /usr) 4. make 5. sudo make install

That is all to it.


Make sure to first install build-essential:

sudo apt-get install build-essential

Afterward, configure should alert you to any other programs or libraries that are required to compile the software.

  • now i installed build-essential using : sudo apt-get build essential, and it downloaded! but still same problem exist – user seven Jan 6 '12 at 14:09
  • Just this: ./configure Save the sudo for sudo make install after compilation succeeds. – user8290 Jan 6 '12 at 14:53
  • In fact you are running as root - so sudo not required. – user8290 Jan 6 '12 at 14:54
  • ams might be on to it... or try bash ./configure – user8290 Jan 7 '12 at 1:58
  • i tried sudo bash +x ./configure and it worked somehow but another error happened in last line, i took screen shot please see it – user seven Jan 7 '12 at 7:56

to compile a program from source, unpack the archive as follows:

tar -xf fooprog.tar

then go into the unpacked directors (usually same name):

cd fooprog

in this folder as first step invoke:


Not all programs come with a configure script but many. Read the README or INSTALL file which is usually in the archive for more information.

After configure succeeded, proceed with:


and if that also succeeded install the software with:

sudo make install

Usually you only need to invoke this last step as superuser (sudo)

If configure fails you should look at the output and install all the packages it requires, especially also build-essential the way, christopher recommended.

  • i used sudo apt-get install build-essential and it downloaded, but still it says command not found – user seven Jan 6 '12 at 13:52
  • mitser user seven... if you do not add the complete output we cannot help you.please copy and paste all steps from the console window into your initial posting. do not leave anything out!!! Further you can check what files exist in the archive.After unpacking just invoke ls in the unpacked archive. If there is no configure file then you cannot invoke it.You could also tell us, which software you try to install. – Michael K Jan 6 '12 at 14:18
  • Dear Mickael K ,sorry for that , i'm not so familiar with linux but i took a screen shot you can see here what i've done and program is bluefish as you can see its name in path up5.iranblog.com/images/ierm22w9cbgnv3jcmkp4.png – user seven Jan 6 '12 at 14:28

Assuming "configure" exists, this message can mean that something referenced by the file was missing.

Try this:

bash +x ./configure

If it still doesn't work, post (some of) the output (edit your question above).

  • thank you it worked , but still in the last line it says another error, i took screen shot and put it above please tell me what does it mean? – user seven Jan 7 '12 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.