0

I am running 2 Ubuntu (14.04 and 16.04) servers and i tried doing the following simultaneously.

I have built cURL v7.54.1 from source on both servers.

I ran phpinfo() to see the module information on the PHP cURL module.

The Ubuntu 16.04 server reports that the PHP cURL module uses cURL v7.54.1.

The Ubuntu 14.04 server reports that the PHP cURL module uses cURL v7.53.1 (which I compiled a few months ago). This is undesirable, as I was hoping that PHP would now be using v7.54.1.

How can I fix my Ubuntu 14.04?

0

Firstly, I had remove all traces of previous cURL installations.

Lastly, I had to compile cURL with option:

./configure --prefix=/usr/local

... and as answered in https://stackoverflow.com/questions/5998680/ubuntu-64bit-11-04-server-and-curl-install-fail by @samir

ln -s /usr/local/lib/libcurl.so.4 /usr/lib/libcurl.so.4

... and also issue command

sudo ldconfig

before removing and re-installing php7.1-curl.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.