0
The following packages have unmet dependencies:
 filezilla : Depends: libdbus-1-3 (>= 1.9.14) but 1.6.18-0ubuntu4 is to be installed
             Depends: libfilezilla0 but it is not going to be installed
             Depends: libgnutls30 (>= 3.4.2) but it is not installable
             Depends: libnettle6 but it is not installable
             Depends: libpugixml1v5 (>= 1.7) but it is not installable
             Depends: libstdc++6 (>= 5.2) but 4.8.2-19ubuntu1 is to be installed
             Depends: libwxbase3.0-0v5 (>= 3.0.2+dfsg) but it is not installable
             Depends: libwxgtk3.0-0v5 (>= 3.0.2+dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.

How can I fix this?

4
  • This post may help askubuntu.com/questions/799363/… Jul 7 '17 at 7:02
  • I tried those answers but didn't work for me Jul 7 '17 at 7:17
  • Phew, it almost looks like you have a mixture of different package versions for different ubuntu versions installed. Is that a fresh ubuntu or did you edit on the sources manually?
    – Ziazis
    Jul 7 '17 at 7:41
  • im using ubuntu version 14.04 and didn't edit anything manually. I have installed some video player after that this problem begins. Jul 11 '17 at 9:18
-1

You can install the package.

make sure the repo sources are up to date

sudo apt-get update

To Install the package:

sudo apt-get install packagename

Once the package determines that you have some missing dependencies, run the following command to fix broken or missing dependencies.

sudo apt-get install -f

Above command will only download the missing dependencies if you have already installed the package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.