0

The problem is on a vaio notebook.

ifconfig sample

enp4s0    Link encap:Ethernet  HWaddr 12:23:34:56:23:52  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:42617276841105360 errors:37290117235967190 dropped:5327159605138170 overruns:5327159605138170 frame:15981478815414510
          TX packets:26635815205560030 errors:21308655600421860 dropped:0 overruns:5327163900105465 carrier:10654327800210930
          collisions:21308655600421860 txqueuelen:1000 
          RX bytes:5327159605138170 (5.3 PB)  TX bytes:5327163900105465 (5.3 PB)

and it's values keep increasing

lspci -nnk |grep -e 0200 -e 0280 -A2

04:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8131 Gigabit Ethernet [1969:1063] (rev c0)
        Subsystem: Sony Corporation AR8131 Gigabit Ethernet [104d:9069]
        Kernel driver in use: atl1c

lsmod |grep atl (shoudlnt it be connected to module "mii"?)

atl1c                  49152  0

modinfo atl1c

Qualcomm Atheros 100/1000M Ethernet Network Driver

sudo ethtool enp4s0

Settings for enp4s0:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  100baseT/Full 
    Advertised pause frame use: No
    Advertised auto-negotiation: No
    Speed: Unknown!
    Duplex: Unknown! (255)
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: Unknown
    Supports Wake-on: pg
    Wake-on: d
    Current message level: 0x0000003f (63)
                           drv probe link timer ifdown ifup
    Link detected: no

the strange thing here too is speed and duplex are always unknown even after sudo ethtool -s enp4s0 speed 100 duplex full autoneg off (as it changes nothing) see https://ubuntuforums.org/showthread.php?t=2239677&page=5

The kernel module "mii" is present on both desktop and the other notebook, while the vaio has it not! and the port it uses is "twisted pair" instead of MII.

all these below didnt work either:
Ethernet device not managed
Ubuntu 16.04 Ethernet issues
Can't connect to Ethernet on 16.04
Ethernet connection Issues on Ubuntu 16.04
Ethernet port and WiFi adapter not detected, Ubuntu 16.04
Ubuntu 16.04 Network Issues
Ubuntu 16.04 outgoing requests issue on Ethernet connection

the above problems happen no matter I use a normal ethernet cable, or a crossover.

EDIT:
my desktop detects the connection to the vaio notebook and everything there looks ok, ifconfig, ethtool etc.
The desktop connects to another notebook without any problems using the same crossover cable too.
The other notebook is also unable to connect to the vaio notebook.

anything else I could try?

  • Are the cables that you're using CAT5 or better? – heynnema Jul 6 '17 at 18:56
  • @heynnema I think it is, btw I solved it be rmmod modprobe atl1c, will post the answer, I expect that solution lasts after reboot as soon I can reboot, thx! – VeganEye Jul 6 '17 at 19:16
0

the solution here was simple, I just needed to
rmmod atl1c

wait a bit

modprobe atl1c

and the LAN ethernet was working perfectly thru crossover cable.

PS.: the MII module seems unnecessary with Atheros

  • I will do more tests to see if this solution will not fail later, b4 marking as solved – VeganEye Jul 6 '17 at 19:18
  • You can verify that atl1c does not depend on mii with the command: modinfo atl1c It has no 'depends' at all. – chili555 Jul 6 '17 at 20:46
  • @chili555 oh, was looking everywhere for that, thx! – VeganEye Jul 6 '17 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.