5

When I start my Ubuntu there is this splash screen:

enter image description here

and i got rid of it by changing this line:

from
GRUB_TIMEOUT=2
to
GRUB_TIMEOUT=0

so it skips the grub right away.

But if I force reset/power off the machine I get this screen:

enter image description here

Now with 30 seconds countdown...

My question is where is this coming from, which file? I want to change it and it's not in /etc/default/grub

8

I found it on my own

in file /etc/grub.d/00_header

line 333

set timeout=${GRUB_RECORDFAIL_TIMEOUT:-30}

I have added this variable in /etc/default/grub file

GRUB_RECORDFAIL_TIMEOUT=0

and now even if i force reboot/power off it will skip the grub

|improve this answer|||||
  • you could also try in your grub setting GRUB_RECORDFAIL_TIMEOUT=N not sure which one of those overwrites which. But if the setting in the grub file works it's probably better than changing the header file. – Ziazis Jul 6 '17 at 12:50
  • I think that wouldn't work because of this if [ "\${recordfail}" = 1 ] ; then set timeout=${GRUB_RECORDFAIL_TIMEOUT:-30} else EOF in header it is strictly set so i think it would be overwritten. But i will try it out now and let you know – lewis4u Jul 6 '17 at 12:51
  • Damn it seems that you were right....it takes that value...i will change my answer. (done) – lewis4u Jul 6 '17 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.