0

I have latest Ubuntu 17.04 zesty. 4.10.0-26-generic #30-Ubuntu SMP Tue Jun 27 09:30:12 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

And ASUS VivoBook Pro N752VX. Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz

My built-in WiFi adapter doesn't work well, so I bought new one - TP-Link Archer T4UH because it claimed linux compatibility. It didn't work out of the box. First I tried to download linux drivers from official TP-Link site (http://www.tp-linkru.com/download/Archer-T4UH.html#Driver). That was version 4.3.13_14061.20150505. But they where uncompatible with my linux kernel. So I tried the another versions: github/diederikdehaas/rtl8812AU - version 4.3.8, 4.3.14, 4.3.20 github/mk-fg/rtl8812au - version 5.1.5 I had also to add my device_id into sources because it was missed there.

lsusb:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:8763 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 0bda:57f6 Realtek Semiconductor Corp. 
Bus 001 Device 005: ID 2357:010e <-- This is my USB WiFi dongle
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

original driver sources contain only (for RTL8812A chipset):

{USB_DEVICE(0x2357, 0x0101),.driver_info = RTL8812}, /* TP-Link - Archer T4U */
{USB_DEVICE(0x2357, 0x0103),.driver_info = RTL8812}, /* TP-Link - T4UH */

And all drivers failed to connect to my WiFi router.

After compiling and installing driver WiFi points become visible in NetworkManager. My WiFi point is configured to use WPA/WPA2 authorization. If I use NetworkManager then it accepts my WiFi password, waits some time and then asks password again. Switching to WPA2 didn't help.

So I decided to use command line to connect.

iwconfig:

tun0      no wireless extensions.

wlxd46e0e11c476  unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

enp3s0f1  no wireless extensions.

Please note - I use for wireless interface name in examples but actual interface name I used there is wlxd46e0e11c476.

Did something like (as root)

# ip link show
# ip link set <wlan0> up
# iwlist <wlan0> scan
# wpa_passphrase <Your_SSID> <Your_passwd> > wpa_supplicant.conf
# wpa_supplicant -B -i <wlan0> -c wpa_supplicant.conf -D wext

and at that point I got:

Successfully initialized wpa_supplicant
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument

I'm not a big specialist in linux and linux hardware and drivers. So my question is about community or people that can help me to originate next steps to make my device work.

  • Please edit your question to add the result of the terminal command: iwconfig and also: lsusb – chili555 Jul 6 '17 at 11:08
0

Finally found that the problem was -D wext. Need to be changed to nl80211 So correct command should be

# wpa_supplicant -B -i <wlan0> -c wpa_supplicant.conf -D nl80211
# dhclient <wlan0>

And that's it.

Don't know what is the problem with network manager - why it can't connect to this WiFi. But at least have working WiFi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.