9

Lately my syslog is being flooded with these messages:

localhost systemd-resolved[1632]: Using degraded feature set (TCP) for DNS server 127.0.1.1.

I'm on Ubuntu 17.04. resolv.conf is auto-configured, i.e. I did not mess with it.

Question: How can I stop the flooding of my syslog? It grows to several gigabytes, filling up my root partition.

3
  • 1
    That is a normal message if you use "bind" and did not configure it. So did you install that perhaps? If so see digitalocean.com/community/tutorials/… – Rinzwind Jul 6 '17 at 6:38
  • There's only the bind9-host package on my system and when I try to remove it, it wants to remove ubuntu-standard and some other things along with it. – bovender Jul 6 '17 at 8:53
  • 1
    I have the same issue on my system, and also, DNS resolution no longer works. I haven't figured out the cause yet, but I believe NetworkManager incorrectly puts nameserver 127.0.1.1 into my /etc/resolv.conf. If I understand it correctly, it should only do that when dnsmasq is being used, but I don't have that installed. – Martin von Wittich Jul 14 '17 at 18:15
2

I had an old record lying in my /etc/resolvconf.conf that injected 127.0.0.1 whenever network went up:

# /etc/resolvconf.conf
# Configuration for resolvconf(8)
# See resolvconf.conf(5) for details

resolv_conf=/etc/resolv.conf
# If you run a local name server, you should uncomment the below line and
# configure your subscribers configuration files below.
name_servers=127.0.0.1

So commented it out, then ran resolvconf -u and my issue was fixed. Currently using systemd-networkd, so dont't know for sure if this will help OP's specific case.

However, NetworkManager has a setting to make it stop updating resolv.conf:

[main]
dns=none

More information in another question at network manager: how to stop nm updating /etc/resolv.conf

Update: The same kind of message appears when my upstream DNS servers are down/not responding. However, containing the upstream IP addresses on a round-robin basis between the server alternatives.

Update #2: When using systemd-networkd, if you've opted to use the following DNS settings for your interface in /etc/systemd/network/<iface>.network:

[DHCP]
UseDNS=true

which is the default setting, then it will not be using your local systemd-resolved instance, but instead use the a server from DHCP. Set UseDNS=false to use your systemd-resolver. Read man systemd.network for detailed information.

1
  • 1
    There's no /etc/resolvconf.conf on my Ubuntu 17.04 system, and the (few) files in the subdirectories of /etc/resolvconf do not contain this line. I'd like to keep NM updating my resolv.conf so I can use the most proximal name servers depending on the current network environment that I am in (this is on a laptop). – bovender Jul 21 '17 at 10:57
0

It may be that your /etc/resolv.conf is not pointing to /run/resolvconf/resolv.conf, which is where this information is now managed. You can check this using:

ls -l /etc/resolv.conf

This should come back with something like:

lrwxrwxrwx 1 root root 27 Jan 22 08:50 /etc/resolv.conf -> /run/resolvconf/resolv.conf

If not, then check your system has this file:

ls -l /run/resolvconf/resolv.conf

And if so, switch to using it:

sudo rm /etc/resolv.conf; sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf

You might want to look in /etc/systemd for the configuration files, such as /etc/systemd/resolved.conf.

1
  • 1
    Thanks. I actually solved the problem a little while ago by uninstalling and re-installing network-manager. At that time, I had forgotten about this AskUbuntu question. Interestingly, my /etc/resolv.conf right now is not a symbolic link. But I better not touch it as it currently works as expected. – bovender Jan 24 '18 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.