14.04 LTS.
Auto updated, rebooted, bios posts, goes to a black screen with blinking cursor.
Holding shift after Bios post will display the letters GRUB but nothing else.
No other inputs appear to have any effect (tried "alt ->" and "alt<-"; also tried alt+ctrl+f1; and typing my password + enter)
I can still dual boot into Windows.
I can boot into a Live CD but unsure how to fix this.
Last month I had this problem:
After Repairing Deleted Kernel, why would GRUB still not boot into Linux.
I just tried those steps again, shooting in the dark, to no avail.
Please help... What is going on with my Ubuntu install!?

  • A good start would be to start ubuntu via additional choises of grub with the previous kernel... This will do clear if the new kernel causes your problem – koleygr Jul 5 '17 at 20:15
  • Also are the updates that you did ordinary updates? or you upgraded to 16.04? – koleygr Jul 5 '17 at 20:16
  • But how do I start Ubuntu with GRUB when GRUB never appears? Also, I ran auto updates and auto installed whatever it gave me (a long list, and it took a lot longer than usual) – MOwens Jul 5 '17 at 20:32
  • did you tell it to remove the current kernel while you were updating? – ravery Jul 5 '17 at 20:43
  • @MOwens sorry, I thought you could boot. Offtopic:(when we say I can dual boot we mean I can boot in both. Otherwise it is better to say I can boot on Windows) – koleygr Jul 5 '17 at 20:50

if you get grub. from a LiveCD. press c to get a command line. change the drive refences as need for your install

From grub type ls (hd0,2)/boot/

you should see a file named vmlinuz or linux, and initrd.img. with version numbers

type: linux (hd0,2)/boot/vmlinuz-#### root=/dev/sda2 or linux (hd0,2)/boot/linux-#### root=/dev/sda2 depending on what you found with ls (hd0,1)/ then

`initrd (hd0,2)/boot/initrd-#####.img`

boot

if you get initramfs rescue mode -- enter your password then startx you should now have a desktop.

use gparted to check your file system, if it reports an error, then you need to boot from a LiveCD or other media to fix it .... DO NOT attempt to repair a mounted partition.

The following three commands fix many grub boot problems. They run quick so just do all three instead of trying to find which one you need.

sudo install-grub /dev/sda, sudo update-grub and sudo update-initramfs -u

reboot and see what you get

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.