0

I am trying to install 16.04LTS on an Asus X554L laptop. It previously had Windows 10, which became corrupted, and I had no desire to repair or reinstall Windows, and since I had been using Linux for almost 10 years now I decided to install Ubuntu on it (I also tried Debian). The installation can only be booted through UEFI, and it usually runs fine at first, but near the end it tells me that the installation of GRUB signed keys has failed.

Options for Secure Boot, CSM, and boot override within BIOS have been locked out of the user's ability to edit. Secure Boot is enabled, and CSM is disabled. I am still able to boot the Ubuntu installer (not Debian), however the computer refuses to boot the OS after it is installed. The only related option I am able to edit is insert or delete "Secure boot variables" which are the proprietary keys Ubuntu is lacking to install GRUB onto MBR.

Deleting all secure boot keys prevents the comptuer from booting the installers kernel, it just drops at the grub console

  • 1
    It's likely possible to disable Secure Boot. (DO NOT enable the CSM, though!) The option to change the Secure Boot settings may be locked out by some other option -- maybe you need to enter a password, for instance. I'd suggest looking for such an option and then disable Secure Boot, at least temporarily. – Rod Smith Jul 6 '17 at 13:04
0

It sounds to that grub update failed not the signed kernels.

I have noticed that the file that adds the efi-firmware option to the grub menu errors on some computers. grub installs but the initial grub-update to create the config file is what fails.

the file /etc/grubd/30_efi-firmware needs to be edited to remove the if/then statement. then update grub.

I've edited mine to read:

gettext_printf "Adding boot menu entry for EFI firmware configuration\n" >&2

cat << EOF
menuentry 'uefi-firmware' {
fwsetup
}
EOF

if your installer has a command prompt at the bottom. you can make this change and reinstall grub (nano is the text editor. you may have to comment out the gettext_printf line also ).

if not then, continue with out installing grub, and make the change from a LiveCD. and update grub.

  • i made the edit removing the if/then, but how do i run update-grup if im booted from the live usb? – Nick Bailuc Jul 6 '17 at 2:19
  • 1
    askubuntu.com/a/931327/694267 you can use these directions to boot from the grub command prompt. press "C" in the grub menu and adjust the drive reference for your computer – ravery Jul 6 '17 at 2:24
  • ive specified both the kernel and initrd but when i boot it says no init found, try passing init=bootarg, and then it stops at (initramfs): random crng init done. this happens whether i use the regular vmlinuz or the efi.singed vmlinuz – Nick Bailuc Jul 6 '17 at 3:22
  • did you set the root correctly ? (hd0,2)/vmlinuz root=/dev/sda2 ... (hd1,2)/vmlinuz root=/dev/sdb2 .... etc ..... where is ubuntu installed? – ravery Jul 6 '17 at 3:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.