8

Whenever my computer completely drains its battery (those rare cases when I use it until it turns off), after I plug it it wont charge. The battery indicator will show 0% and "Estimating..." where it should say how much time until fully charged. I know it is not just displaying jt wrong because if I unplug the laptop it turns off. My solution so far is to boot Windows, charge up to 1% and then boot back into Ubuntu. That works, so I know it's not the hardware.

What I am using: Thinkpad X1 Carbon 4th Gen, Ubuntu 16.04, I have TLP installed

  • It doesn't actually charge or just doesn't show progress? You tried charging it and just rebooting to see if it was charged? – Ziazis Jul 5 '17 at 12:21
  • It won't charge. If after an hour I unplug it, it turns off. I have to boot into windows, charge up to 1% and the go back to Linux – ig343 Jul 5 '17 at 13:03
  • +1 Because I have similar issue with different model of laptop running 16.04 release. I will post a workaround with some details based on my experience, but so far no real solution to this date. – clearkimura Sep 1 '17 at 8:17
  • The computer should be able to charge shut down, so this is not an Ubuntu problem, but a hardware one. Maybe you could configure Ubuntu to shut down at 5% battery level, so you don't end up in the 0% situation? – Soren A Sep 1 '17 at 14:11
  • It is a software problem crearly as it doesn't happen with Windows. The computer charges just fine when it is shut down. – ig343 Sep 1 '17 at 14:21
2

I have documented a workaround for the said issue, which is applicable to ASUS notebook PC that I have been using since late-2014.

The workaround based on what I have documented in mid-2016:

  1. When the battery is empty, or when notebook PC is unable to power on, connect the notebook PC to the charger and start charging.

  2. Do not boot to Linux. The notebook PC should remain off whilst charging. Wait for 10~30 minutes, depending on charging rate.

  3. Afterwards, turn on the notebook PC and boot to Linux. Login to the desktop and confirm that the battery is charging from the Power Manager or using upower -d command in Terminal.

The important point is notebook PC should be turned off when charging battery from empty, otherwise charging will not start. Even suspend will prevent the battery from charging at all. I have observed that again and again, whenever I had left my notebook PC unused for weeks.

Note: Documented for ASUS X200MA, running Xubuntu 16.04 LTS 64-bit.

Firmware issues

Despite the workaround has worked for my notebook PC, I have thought of other issues that may be related to the question:

The latter may be influenced by proprietary firmware for power management, which can only be fully utilized by Windows operating system but not Linux. This may explain the condition when battery is empty, charging may start when running Windows but does not start when running Linux.

Battery treatment

There is one critical advice: Lithium ion battery should not be fully discharged or should not be used until empty (see Battery treatment on ThinkWiki).

Regardless of running Windows or Linux, the operating system supposedly has sane default settings to prevent the battery from fully discharged. As a result, the system will automatically suspend, hibernate or even shut down when battery level has reached to certain percentage. This however, may be changed by users.

TL;DR Forget Windows and Linux. Charge the battery from empty when the power is off. Battery should not be fully discharged because of potential damage or reduced battery life.

  • 1
    Thank you for answer, clearkimura. This workaround is a way to overcome the problem, but it is not really an answer to my question or a solution, as I am looking for a fix and not a workaround. Although it is useful and I will upvote it, I won't accept it as the answer. – ig343 Sep 1 '17 at 14:24
0

From your question it seems there is no problem in Charging. Just keep charging some longer time and it will start displaying expected time or charged %.

There might be some display related problem from s/w side. So just charge at least half an hour and then boot/start.

  • 1
    No, there is a problem with charging. It wont charge no matter how much time I leave it. – ig343 Jul 5 '17 at 13:02
0

Maybe it could be because Ubuntu uses more battery and resources than Windows. Just look at the minimum system requirements for each OS.

Ubuntu: 2 GHz dual core processor or better, 2 GB system memory, 25 GB of free hard drive space

Windows: Processor: 1 gigahertz (GHz) or faster processor or SoC. RAM: 1 gigabyte (GB) for 32-bit or 2 GB for 64-bit. Hard disk space: 16 GB for 32-bit OS 20 GB for 64-bit OS. Graphics card: DirectX 9 or later with WDDM 1.0 driver. Display: 800x600.

Windows obviously needs less resources from your computer because of the broad range of PCs that use it. Therefore, Ubuntu uses more resources from your PC, causing it to use more electricity.

  • ubuntu runs fine on a 1Ghtz provcessor, and actually uses less resourcess than windows. Also, this has no effect on charging since the chargers are designed to operate the computer at full freq (max power usage) while charging – ravery Aug 31 '17 at 1:45
  • ubuntu doesn't (necessarily) use more battery than windows and charging works just fine in any other escenario – ig343 Aug 31 '17 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.