0

I'm running Ubuntu 17.04 on an ASUS UX303 notebook. This laptop has two GPUs: an integrated Intel one, and a discrete NVIDIA 940M. I recently decided to install the non-nouveau NVIDIA drivers (specifically, nvidia-381), but after doing so, I encountered a problem: whenever I open the lid after closing it, I get a completely black screen. If I leave the laptop on the black screen for long enough, I hear the fan begin to go crazy.

When my screen goes completely black, I can't Control-Alt-FX my way over to any consoles. The only thing that I can do is hold down the power button. This issue isn't only happening with the nvidia-381 driver -- I've tried the nvidia-375 and nvidia-378 drivers, and yet the problem still persists. I've also tried to uninstall these drivers and install Nouveau, but I've had my own problems with that (when I install the Nouveau drivers from software-properties-gtk, I get weird screen tearing and lshw tells me that the 3D controller is unclaimed). At this point, my Ubuntu system is more borked than it was before I installed any drivers, Nouveau, NVIDIA, or otherwise. Could anyone please tell me how I can remedy this issue?

For reference, here's my lshw -C video output:

  *-display                 
       description: VGA compatible controller
       product: HD Graphics 520
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:124 memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff
  *-display
       description: 3D controller
       product: GM108M [GeForce 940M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:128 memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff

And here is my xorg.conf:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

Once again, I would be extremely grateful if someone could help me.

2 Answers 2

0

I'm having the same issue in Ubuntu Gnome 17.04 with my Asus R558UQ. It's far from being a solution, but to me disabling the Secure Boot in BIOS/UEFI menu prevented the black screen from reappearing.


EDIT: This worked for me in Ubuntu 18.04.

DISCLAIMER : I didn't came up with this solution. It was an issue I've had problems with so long that I decided to save the answer as a PDF in my Google Driver so as not to loose it. And now I can't find the link, so I'm copypasting someone's else answer.


Hi all

How to solve the issues of suspending , hibernating and wakeup with nvidia-370.28 first step : Just open this file sudo gedit /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla and enable hibernation

... [Disable hibernate by default in upower] Identity=unix-user:* Action=org.freedesktop.upower.hibernate ResultActive=yes

[Disable hibernate by default in logind] Identity=unix-user:* Action=org.freedesktop.login1.hibernate ResultActive=yes

second step : on /etc/default/grub :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1 vga=0 rdblacklist=nouveau nouveau.modeset=0 "

third step : sudo gedit /etc/initramfs-tools/modules and add the following modules

nvidia nvidia_modeset nvidia_uvm nvidia_drm

fourth step : sudo update-initframs -k "yourkernel" -u

fifth step : reboot and you are done . Note : if are not on Ubuntu follow this:

PolicyKit Local Authority policy to enable suspend and hibernate for all users. Should be installed into /var/lib/polkit-1/localauthority/90-mandatory.d or /etc/polkit-1/localauthority/90-mandatory.d

file to edit under the directory mentionned : enable-suspend-and-hibernate.pkla copy this text and save and continue other steps

[Completely disable suspend and hibernate]

Identity=unix-user:* Action=org.freedesktop.upower.suspend;org.freedesktop.upower.hibernate;org.freedesktop.login1.s uspend*;org.freedesktop.login1.hibernate* ResultAny=nyes ResultInactive=yes ResultActive=yes

regards Mounir

PS : I hope it works for you AMEN


For me, it not only prevented the black screen after hibernating but also solved the freezing when shutting down/restarting after hibernating using the Xorg drivers. Hope it works for you too, let me know :) !

Nehuen

0

I am using Ubuntu 18.04 and was having the same issue in my ASUS R542U, it started when I installed the Nvidia drivers . To solve the problem I changed the option of suspending screen after closing the lid of laptop.


To do this, Type this in the terminal

sudo gedit /etc/systemd/logind.conf


Now just change this line

#HandleLidSwitch=suspend

  TO

HandleLidSwitch=ignore

And then save the file and reboot your system. That should do it.


Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.