18

I tried the suggestions from other threads and nothing has worked. Chromium shuts down immediately from both launcher and command line. I've removed Chromium thoroughly and reinstalled. Firefox works fine. Tried the following:

sudo apt-get remove chromium --purge
rm -rf ~/.config/chromium
rm -rf ~/.cache/chromium
sudo rm -rf /etc/chromium

I've reinstalled several times using Ubuntu Software Updater.

When I launch from the command line, here is what I get:

chromium-browser --password-store=basic
Received signal 11 SEGV_MAPERR 000000000010
#0 0x7f85710a8425 base::debug::StackTrace::StackTrace()
#1 0x7f85710a880b <unknown>
#2 0x7f85713d3390 <unknown>
#3 0x557a2f3badc8 <unknown>
#4 0x557a2f3bd656 <unknown>
#5 0x557a2f3bddf9 <unknown>
#6 0x557a2f3be143 <unknown>
#7 0x7f8571123821 <unknown>
#8 0x7f85710a9eea base::debug::TaskAnnotator::RunTask()
#9 0x7f85710d2e90 base::MessageLoop::RunTask()
#10 0x7f85710d497d base::MessageLoop::DeferOrRunPendingTask()
#11 0x7f85710d583d <unknown>
#12 0x7f85710d6300 base::MessagePumpLibevent::Run()
#13 0x7f85710d1f15 base::MessageLoop::RunHandler()
#14 0x7f85710fc628 base::RunLoop::Run()
#15 0x7f8571128e36 base::Thread::ThreadMain()
#16 0x7f8571123726 <unknown>
#17 0x7f85713c96ba start_thread
#18 0x7f855aa783dd clone
r8: 000000000000002e  r9: 0000557a30e116ec r10: 0000000000000000 r11: 00007f855ab05f50
r12: 00007f84c9ff8ff0 r13: 0000000000000008 r14: 0000000000000008 r15: 00007f84c9ff8eb0
di: 0000000000000000  si: 00007f84c9ff8eb0  bp: 00007f84c9ff8f00  bx: 00007f84c9ff8eb0
dx: 0000000000000065  ax: 0000000000000000  cx: 0000557a33308720  sp: 00007f84c9ff8e60
ip: 0000557a2f3badc8 efl: 0000000000010206 cgf: 0000000000000033 erf: 0000000000000004
trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000010
[end of stack trace]
Calling _exit(1). Core file will not be generated.

But when I use the Ubuntu Software updater, the application allows me to install a 2nd Chromium, a 3rd Chromium or more. Sometimes the updater sees an existing Chromium and says "Remove" instead of "Install." If I select "Remove," it removes one of the Chromium's, but not all of them. Trying to remove them from the command line does not have an effect:

sudo apt-get remove chromium --purge
[sudo] password for karen: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'chromium' is not installed, so not removed
The following packages were automatically installed and are no longer required:
libmircommon5 linux-headers-4.4.0-31 linux-headers-4.4.0-31-generic
linux-headers-4.4.0-62 linux-headers-4.4.0-62-generic linux-headers-4.4.0-63
linux-headers-4.4.0-63-generic linux-headers-4.4.0-64
linux-headers-4.4.0-64-generic linux-headers-4.4.0-66
linux-headers-4.4.0-66-generic linux-headers-4.4.0-70
linux-headers-4.4.0-70-generic linux-headers-4.4.0-71
linux-headers-4.4.0-71-generic linux-headers-4.4.0-72
linux-headers-4.4.0-72-generic linux-headers-4.4.0-75
linux-headers-4.4.0-75-generic linux-headers-4.4.0-78
linux-headers-4.4.0-78-generic linux-image-4.4.0-31-generic
linux-image-4.4.0-62-generic linux-image-4.4.0-63-generic
linux-image-4.4.0-64-generic linux-image-4.4.0-66-generic
linux-image-4.4.0-70-generic linux-image-4.4.0-71-generic
linux-image-4.4.0-72-generic linux-image-4.4.0-75-generic
linux-image-4.4.0-78-generic linux-image-extra-4.4.0-31-generic
linux-image-extra-4.4.0-59-generic linux-image-extra-4.4.0-62-generic
linux-image-extra-4.4.0-63-generic linux-image-extra-4.4.0-64-generic
linux-image-extra-4.4.0-66-generic linux-image-extra-4.4.0-70-generic
linux-image-extra-4.4.0-71-generic linux-image-extra-4.4.0-72-generic
linux-image-extra-4.4.0-75-generic linux-image-extra-4.4.0-78-generic
linux-signed-image-4.4.0-59-generic linux-signed-image-4.4.0-62-generic
linux-signed-image-4.4.0-63-generic linux-signed-image-4.4.0-64-generic
linux-signed-image-4.4.0-66-generic linux-signed-image-4.4.0-70-generic
linux-signed-image-4.4.0-71-generic linux-signed-image-4.4.0-72-generic
linux-signed-image-4.4.0-75-generic linux-signed-image-4.4.0-78-generic
snap-confine torsocks ubuntu-core-launcher
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

Now I have three Chromium Launcher icons that flash Chromium before immediately shutting down.

The results are confusing because on occasion I've been able to use one of the Chromium's to get the Google login. When I login, the Chromium shuts down immediately.

Logging in as guest produces the same results. Also, here is output from fsdk:

sudo fsck -n fsck from util-linux 2.27.1 e2fsck 1.42.13 (17-May-2015) 
Warning! /dev/sda8 is mounted. Warning: skipping journal recovery because doing a read-only filesystem check. /dev/sda8: clean, 654869/57204736 files, 7153620/228803072 blocks fsck.fat 3.0.28 (2015-05-16) 
0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt. Automatically removing dirty bit. Leaving filesystem unchanged. /dev/sda1: 198 files, 8082/65536 clusters

The only thing that's kept Chromium from folding up is the answer given below to start it with

chromium-browser --disable-extensions

There is an identical post from exactly the same day and one answer was to use chrome instead of chromium. Chrome is working fine and I've removed chromium entirely. I consider this matter closed. Thanks to Alex O. in Chromium crashes as soon as I log in

8
  • Just noticed after the last reboot that the launcher icons for the extra Chromiums are gone. Did a fresh install from the command line. Chromium came up so I went to Yahoo website, then closed Chromium. When I went to open it, it flashed and vanished.
    – KCinAZ
    Jul 4, 2017 at 17:52
  • What happens if you run Chromium in the guest account? Have you done a fsck on your hard disk?
    – heynnema
    Jul 4, 2017 at 20:22
  • Ran fsck from grub-boot-menu. Problem still exists.
    – KCinAZ
    Jul 5, 2017 at 1:06
  • Just to be clear... guest account Chromium problem still exists... and fsck from grub-boot-menu fails fsck... or still fails Chromium after fsck repairs?
    – heynnema
    Jul 5, 2017 at 3:06
  • 2
    Possible duplicate of Chromium crashes as soon as I log in
    – karel
    Jul 6, 2017 at 5:03

6 Answers 6

24

Surprise, surprise! It seems to be the latest cast "fix." The media router extension was enabled by default for 59 and now it crashes like 58 did when you enabled it manually.

Start chrome with:

chromium-browser --disable-extensions

Navigate to chrome://flags, search for "media router" and set it to Disabled.

Bug report at https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1702407

There are now testing packages linked from the bug report that appear to resolve the issue. Try them and report your results.

0
4

1) Start Chromium on the command line with:

chromium-browser --disable-extensions

2) Type this into the address bar of Chromium:

chrome://flags

3) Press ctrl-F and Search for "media router", then set it to "Disabled".

Source: Ubuntu Bug 1702407 | Comment 19.

1
  • this worked just fine
    – silpol
    Jul 20, 2017 at 22:33
3

It's not a real solution, but if you can live without extensions,

chromium-browser --disable-extensions

has stopped chromium from crashing on me.

If you want to close the terminal that spawned the Chromium process without closing Chromium use:

nohup chromium-browser --disable-extensions <&- >&- 2>&- &

Edit: This also started for me today.

Chromium 59.0.3071.109 Built on Ubuntu , running on Ubuntu 16.04

5
  • karen@karen-Lenovo-ideapad-310-15ISK:~$ chromium-browser --disable-extensions/usr/lib/chromium-browser/chromium-browser: error while loading shared libraries: libffmpeg.so: cannot open shared object file: No such file or directory
    – KCinAZ
    Jul 5, 2017 at 1:36
  • Interesting error message about loading shared libraries...
    – KCinAZ
    Jul 5, 2017 at 1:37
  • Fixed libffmpeg.so (reinstalled ffmpeg). Chromium comes up with chromium-browser, but if I kill the terminal, it disappears. Making progress, but Chromium cannot be launched without the terminal.
    – KCinAZ
    Jul 5, 2017 at 1:58
  • You are correct Therealtahu -- I can run Chromium only when I do chromium-browser --disable extensions. Chromium will run until the terminal is closed.
    – KCinAZ
    Jul 5, 2017 at 4:16
  • @KCinAZ: Could you please edit your post, when you want to add information? Especially file or program output listings (with the help of the {} button in the editor toolbar) will be much more readable there; alternatively you can use a pastie service for longer listings and include the link of your pastie in your question. Overall it’s best to have everything relevant in one place. Additionally, comments may be deleted for various reasons. Thanks. Jul 5, 2017 at 8:43
0

Same here and I only use it for signal...

Since the last update, on 59.0.3071.109-0u, if I start it without extensions and then with:

chromium-browser --disable-extensions && /usr/bin/chromium-browser --profile-directory=Default --app-id=bikioccmkafdpakkkcpdbppfkghcmihk

it runs for a few minutes before crashing in the same way...

(16.04.2 with mainline 4.9.35)

0

somehow something changed in: /usr/lib/chromium-browser

copied files from backup into that directory and browser worked again.

if it happens again, I'll post which file changed or was deleted.

0

There are some answers here and it's fine. However I see one fundamental problem:

Why Chromium started after I logged into my Ubuntu box when I haven't started Chromium?

BTW: I've used this command to remove Chromium

sudo apt-get remove chromium-* --purge

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .