0

Computer: HP Stream Notebook 11.6" Intel Celeron CPU N2840. WiFi was working in Windows, replaced Windows with Ubuntu 16.04. I have no Ethernet connection, so have not been able to connect to the internet at all. What I've tried: gone to Software & Updates/Available Drivers, 802 is selected. I suspect the problem may lie in the Add/Edit Wifi connections box, in the Device field. If that is for my computer's NIC MAC address, I have been unable to find it with lshw or grep commands because the portion of the resulting display which would contain my MAC is in the eth0 section, and I have no Ethernet connection. Suggestions and redirection welcome.

lspci -knn | grep Net -A3; rfkill list:
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
    Kernel driver in use: wl
    Kernel modules: ssb, wl

$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Jul 4 '17 at 16:30
  • Thanks Pilot6, I ran the 2 commands you said, and have added the results to the original question. – mrhyde7600 Jul 13 '17 at 19:08
1

You installed a wrong driver for your wireless device.

Connect to the internet by wire and run

sudo apt purge bcmwl-kernel-source
sudo apt install firmware-b43-installer
sudo modprobe -r wl
sudo modprobe b43

Your Wi-Fi should be working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.