4

It's an interesting problem I never saw before. The hard disk of this laptop has a harware problem (on a specific sector it got some problems).

That's why if I let Ubuntu installation to create the partitions, using the whole space, that fails.

However, if I create the partitions, without using the entire space, that passes (the partitions are created and it goes forward to installation).

I created the following partitions, on the 500GB hard drive:

  • 100GB ext4, mount: /
  • 2GB swap
  • 1GB EFI

If I don't create the EFI partition, Grub fails to be installed. So, I saw that Ubuntu was going to create the EFI partition, by default, and I created it manually when selecting the Something else option.

The installation went well. It even displayed the alert saying that everything was successful.


But, when restarting the laptop, it doesn't boot from the HDD. I don't see the HDD option in the BIOS.

I tried to add it, but it asks me about the path for boot––which I have no idea what it is.

How to solve this? How can I get Ubuntu running on this laptop?

It doesn't have Secure Boot or anything similar in BIOS.

I have a live usb drive which I can use to access the hard drive, which works nicely.

  • Are you sure it is not the HDD's problem? Because it seems like it to me :-) – RonnieDroid Jul 4 '17 at 8:09
  • @RonnieDroid I can mount the HDD and access it. Do you think it would work in that case? – Ionică Bizău Jul 4 '17 at 8:11
  • @RonnieDroid Before, this laptop ran Windows 10. And it got some problems, which seem to be like hardware problems to me. I saved the documents successfully, by mounting it in readonly mode. I wasn't able to mount it in write mode, using a live USB stick. – Ionică Bizău Jul 4 '17 at 8:12
  • It may, it may not, you better know where the damage is and leave that space empty. Or you better get a new HDD because I have fought with such HDD and it is a pain in the neck – RonnieDroid Jul 4 '17 at 8:16
  • well for my HDD, even after cutting the damaged sectors, the problem still exists, your system was slow when with Windows 10 right? – RonnieDroid Jul 4 '17 at 8:18
6
+50

Your problem is mostly related to the bootloader rather than the HDD itself

To fix that, boot into your Ubuntu Live-usb and from there do this

open the terminal by pressing ctrl+alt+T

then copy past this commands to it one after another,

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair

and by this you will install a tool called boot-repair.

open boot repair from Dash and you'll get this window

enter image description here

choose the recommended repair and follow the steps.

Note you have to be connected to the Internet when using boot-repair.

Note it can take some time, be patient

| improve this answer | |
4

Although RonnieDroid's answer is likely to solve your immediate problem, using a modern disk that reports bad sectors is asking for trouble. Modern hard disks reserve a few sectors so that bad sectors can be mapped out and replaced with the good ones. This should happen transparently, so if you're actually seeing bad sectors, that means that the number of bad sectors on the disk has exceeded the number the manufacturer set aside. When this happens, it usually means that the disk is in the process of failing catastrophically. It's likely that the number of bad sectors will begin to increase -- possibly quite suddenly and rapidly. The result is likely to be a nightmare to recover even some of your data at best, and at worst, a total loss of all data on the disk. There's no way of knowing how long it will be before this begins to happen.

In sum, I STRONGLY recommend that you replace that disk IMMEDIATELY. If a delay is unavoidable, be sure to back up any important data on the disk, since it could easily fail completely at any time.

| improve this answer | |
  • Yes, boot repair did fix the problem. Using 100GB of 500GB with the hope it won't break on these sectors, lol. :D I did recommend my friend (the owner of the laptop) to replace the disk/laptop and showed her how to use Google Drive/documents in the cloud for the more important ones. Also backups. Thanks! – Ionică Bizău Jul 4 '17 at 16:07
1

the hard drive boot option disappeared because you erased /efi/boot/bootx64.
this it the default media path and must be there for device boot.

grub installs at /efi/boot/ubuntu/grubx64.efi or /efi/boot/ubuntu/shimx64.efi for secure boot.
this gives a OS boot option.
external media will require the device boot option (default media path).

the boot repair program given in the first answer replaced this missing file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.