2

I reinstalled Ubuntu 10.10 with Compiz and have suddenly lost the gradient shadow on my gnome menu bar (Top), I was wondering how can I get it back?

I already have the value of "any" set in Window decorations and the shadow is applied to windows, but just not the gnome bar.

I'm running the theme Ambiance with the faneza icon set

  • 'Half duplicate' of How to remove shadow from gnome-panel? - obviously you'll want the opposite of the answer there! – 8128 Oct 25 '10 at 8:46
  • Hold on there trigger! I already have the value of "any" set in Window decorations in compiz and yet I have no shadow. – James White Oct 25 '10 at 8:50
  • It's a clean installation? What theme do you use? Did you modify something? Do you have panel shadow with Metacity (without effects)? – skalka Oct 25 '10 at 10:16
  • I'm using Ambiance and only changed the icons to the faenza set. Apart from that, all default. I recently reinstalled and remembered seeing the shadow but since enabling Compiz it's gone. – James White Oct 25 '10 at 15:59
2

I found out that shadow isn't applied on my gnome top bar because I had disabled desktop icons, no idea why that would be, but instead of disabling desktop icons completly I decided to just disable generated icons for my mounted volumes.

1

Reload the panel with $ killall gnome-panel. When it reloads it will be picked up by Compiz and given a shadow.

  • Thanks but after the panels reloaded I still see no shadow on the top bar – James White Oct 25 '10 at 15:58
  • Not to sound daft, but do you have a background that is light enough to show the shadow? – Jonathon Oct 25 '10 at 16:07
  • I have a light background set right now and it's not showing, I just cycled through a couple of backgrounds to make sure I wasn't being dumb and no shadow. – James White Oct 25 '10 at 16:08
  • Something that is interesting though, I've noticed that my theme has randomly changed without me changing anything, back to Ambiance with the Ubuntu font, which does has the shadow on the top bar but on restart or logging out and in again, it changes back to my set theme. – James White Oct 25 '10 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.