1

I’ve been having problems with Seahorse lately. I suspect an update, but can’t say exactly when it started. It may also be two co-incidental problems.

In Thunderbird I use the Enigmail add-on to sign messages using PGP key. When you type in the passphrase there is an option to have it remembered (presumably by Seahorse), but this doesn’t work any more. Every session it asks for the passphrase again.

In Nemo (or Nautilus) if I do an adhoc connection to a SMB share and choose an option to remember the password, it is not saved.

If I run Seahorse (Passwords and Keys) there is no Passwords section, only Certificates, PGP Keys and Secure Shell. On the other 16.04 system I have, there is a Passwords section and the keys are in ~/.gnome2/keyrings/. On this computer (upgraded from 14.04) the keys are in ~/.local/share/keyrings/ and there is no ~/.gnome2/keyrings/ folder. I see references to both, but which is right?

Also if I choose to create a new item in the GUI, the options for creating a new Password Keyring or Stored Password (which are available on the clean install) are missing.

2

I have found the solution, the question is related to this bug: https://bugs.launchpad.net/ubuntu/+source/gnome-keyring/+bug/1689825

The last fix found is to execute: sudo apt autoremove --purge dbus-user-session.

dbus-user-session is installed with flatpak.

  • Read through that thread, but haven’t tested as yet. Thanks! – Moilleadóir Jul 23 '17 at 7:53
  • Removing dbus-user-session has fixed the immediate problem (Seahorse now shows passwords again, Thunderbird/Enigmail can now access the keyring), but (even after a reboot) I now have the bug described in that thread — I’m asked for the login keyring password at every login. I’ve never used auto-login on this install and I haven’t changed my password. None of the supposedly answered questions about it here actually have a solution; only the workaround of removing the keyring password. It seems voodoo and guesswork is the best askubuntu has to offer in this area. – Moilleadóir Jul 25 '17 at 9:14
  • Strange, after removing this package, I had nothing to do... – onda47 Jul 25 '17 at 13:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.