1

I installed Ibus Preferences & Anthy from Discover as well as ibus & ibus-anthy from terminal, but Ibus doesn't seem to appear when I restarted the system. I'm trying to type Japanese, so I installed Anthy.

I saw similar threads here (Notable: No iBus icon in Kubuntu 12.04), but there have been a few integer versions now, so does this issue still persist where Ibus needs certain GNOME icons, or is this something new?

I'm running Kubuntu 17.04

Edit 0: GNOME Icon theme is installed already.

Edit 1: Upon purging everything and reinstalling just ibus & ibus_anthy there appears to be the same issue. Also, the ibus panel can be made to appear by searching for ibus-preferences in the super search window, and there it will ask you to start the ibus daemon. This shouldn't be necessary though, it should just be there at system start. Additionally, ibus doesn't remember when I set anthy as an IME in the preferences. It's just not on the list & super + space does nothing

1

If managed to fix it! I removed the directory ~/.cache/ibus I had before migrating from Kubuntu 16.04 to 17.04. I also removed ~/.config/ibus (but not sure it helped, I tried this one first).

How did I find this?

  • I ran a live USB key of Kubuntu 17.04 and noticed that it worked after installing ibus and ibus-anthy (and setting the environment variables like QT_IM_MODULE).
  • Then tried with my upgraded system, but with a user having a new profile. And it worked.
  • Then I executed in a terminal strace -e open -f ibus-daemon 2>&1 | grep -v ENOENT to see the (existing) files accessed by the program, and I found the cache directory.

On my side, it works better than UIM, so I am pleased. I hope it will help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.