3

I am unable to boot off live USBs of Ubuntu 16.04.2 LTS, Ubuntu 17.04, Kubuntu 16.04.2 LTS, and Kubuntu 17.04 on my desktop. I have tried making the live USB with UNetbootin and Universal USB Installer and I have installed Ubuntu on other computers with the USB working; but whenever I try to boot off a live USB on the aforementioned desktop it starts up then prints this error:

[   3.516984] bcma: Unsupported SPROM revision: 11
[   3.517071] bcma: bus0: No SPROM available

How can I fix this?

6
  • Please describe your computer, at least the brand name and model (with a link to a specification if possible because some models can actually have different hardware). If you built the computer, you can specify the motherboard, graphics chip/card and network chip/card. It makes it possible to give more specific help.
    – sudodus
    Jul 3, 2017 at 17:20
  • 1
    @sudodus I have a Gigabyte GA-Z97x Gamging-GT motherboard, MSI Twin Frozr GTX970 GPU, i7 4790k and a TP-Link Archer T9E wireless card.
    – LilTux
    Jul 3, 2017 at 17:26
  • You may need the boot option nomodeset, and if/when you can get into the system, you can install a proprietary graphics driver for your nvidia chip. See this link: ubuntuforums.org/…. Maybe you need some special tweak for the motherboard too (I don't know). Let us hope that someone who knows will see this and help :-)
    – sudodus
    Jul 3, 2017 at 17:37
  • Congratulations :-) Please tell us the details of the solution - what made it work. It will be useful for other users, who have the same or similar hardware. I can make a 'full answer', that you can accept.
    – sudodus
    Jul 3, 2017 at 17:49
  • @sudodus Oh, I'm new here. I tried to put it all in a solution
    – LilTux
    Jul 3, 2017 at 17:51

3 Answers 3

1

nomodeset and proprietary driver

After a short dialogue in the comment field, you found that it works with the boot option nomodeset. This link, boot options, and links from it describe how to do it.

When you can get into the system, you can install a proprietary graphics driver for your nvidia chip.

Tweaks for the motherboard or the wifi chip/card

Other people with a similar(?) problem may need some special tweaks for the motherboard, or a proprietary driver for the wifi chip/card.

0

Don't know if this is of any help, but i have a multiboot usb with grub4dos and a kali linux .iso on it. I used RMPrepUSB to prepare my usb stick(google how to do it), then copied the .iso file and made a custom menu.lst with this code:

//other code
title Kali Linux 2 x64 LiveCD\n
partnew (%@root:~1,3%,3) 0x00 /images/kali.iso
map /images/kali.iso (0xff)
map --hook
chainloader (0xff)
//other code

So my usb file tree looks like this:

USB
 |-images
 |    |-kali.iso
 |
 |-grldr
 |-menu.lst

I tried this also with ubuntu live and it worked. Hope it will help.

-1

As suggested by @sudodus in the question comments, adding the boot parameter "nomodeset" to the Kubuntu live option in Grub2 allowed me to boot off the USB just fine. It probably had to do with my NVidia GPU. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.