2

I'm having a dell inspiron 7567 in which im not able to use the nvidia gpu (Geforce GTX 1050). At first i only installed the nvidia driver and tried signing the MOK by following the steps from https://gist.github.com/Garoe/74a0040f50ae7987885a0bebe5eda1aa since i'm using UEFI and enabled secure boot.

When i used the command glxinfo|egrep "OpenGL vendor|OpenGL renderer" i found that my laptop was still using the intel gpu even when gazebosim was running.

Then decided to use bumblebee and did all the steps as mentioned in this video. After doing everything in the video i restarted my laptop and i found the indicator as the guy from the video got( it shows me the nvidia logo instead of the intel logo that the guy from the video got ) but was still not able to change to the nvidia gpu with it.

When i tried running optirun glxgears i get the following error

[ 3411.396308] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 3411.396337] [ERROR]Aborting because fallback start is disabled.

for lspci -vnn | grep '\''[030[02]\]' i get

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:591b] (rev 04) (prog-if 00 [VGA controller])

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1c8d] (rev a1) (prog-if 00 [VGA controller])

for sudo inxi -G i get

Graphics: Card-1: Intel Device 591b Card-2: NVIDIA Device 1c8d Display Server: X.org 1.18.4 drivers: (unloaded: fbdev,vesa) tty size: 80x24 Advanced Data: N/A for root

in my bumblebee.conf file i changed Driver= to Driver=nvidia, Bridge=auto to Bridge=primus,replaced nvidia-current with nvidia-378(which is the nvidia driver im using), changed PMMethod=auto to PMMethod=bbswitch the rest of the file is left as default

for sudo lshw -numeric -C display i get

*-display UNCLAIMED
description: VGA compatible controller product: NVIDIA Corporation [10DE:1C8D] vendor: NVIDIA Corporation [10DE] physical id: 0 bus info: pci@0000:01:00.0 version: a1 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress vga_controller bus_master cap_list configuration: latency=0 resources: memory:d2000000-d2ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:d3000000-d307ffff *-display description: VGA compatible controller product: Intel Corporation [8086:591B] vendor: Intel Corporation [8086] physical id: 2 bus info: pci@0000:00:02.0 version: 04 width: 64 bits clock: 33MHz capabilities: pciexpress msi pm vga_controller bus_master cap_list rom configuration: driver=i915 latency=0 resources: irq:126 memory:d4000000-d4ffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff

my nvidia x server settings dont have many tabs. It only shows me application profiles tab and nvidia settings configuration when its supposed to have many more tabs.

i read a lot about this issue on different forums but i still could'nt get it to work. So could somebody please give me a fix for this. Thanks in advance.

  • if you like complicating so much just for installing a driver you should go to arch-linux, since 2013 ubuntu worked well on nvidia drivers for making it easy to install, so type these commands in order sudo apt install intel-microcode and sudo apt install nvidia-xxx I put xxx because you must use the ubuntu recommended driver for your system, and you will know that using ubuntu-drivers devices command this will display the correct nvidia version for your computer, please see this post askubuntu.com/questions/931633/how-to-install-my-nvidia-driver/… – Egon Stetmann. Jul 3 '17 at 23:50
  • i had already done all that but it still didn't work because i tried doing it with secure boot on. This time i redid the whole process after purging all that i had done before and didn't try making it work with secure boot on and it worked. – Hari Narayan Jul 4 '17 at 8:29
3

Bumblebee does not work well on Ubuntu 16. You should use prime.

sudo apt-get install nvidia-378 nvidia-prime

Prior to doing this you should purge bumbleebe and whatever else you installed.

  • prime comes with the nvidia-xxx package so adding next to it is redundant – Egon Stetmann. Jul 3 '17 at 23:47
  • @ previous comment, It doesn't come with it, it recommends it. – doug Jul 4 '17 at 0:22
  • thank you do much!!!! it works!! i used nvidia-381 instead of nvidia-378. Is there a way to use the nvidia driver along with secure boot on ? – Hari Narayan Jul 4 '17 at 8:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.