This question already has an answer here:

I am running ubuntu 16.04 in a dual-boot with Windows 10. The windows 10 boots without problem, so it's not a hardware issue. I did the update of ubuntu and rebooted my machine as requested. Now -every- time I get to the login screen the machine freezes. My machine is a Dell Inspiron 15 3000 Series. These are the hardwarde specs for my machine.

The solutions I have tried so far are:

  1. booting in recovery mode and running the file system check tool
  2. booting in recovery mode and booting in failsafegraphics mode.
  3. booting from an earlier kernel (also repeating #1 and #2) using an earlier kernel.
  4. I tried booting using (upstart) but the screen just goes black and never boots.

This could very easily be a graphic driver problem, but I have no idea how to fix it. Any ideas would be greatly appreciated... thanks.

UPDATE: My computer is definitely affected by the c-state bug. However, my machine hangs before I can boot and open a terminal to fix the bug. I tried the temporary edit to grub to pass a the kernel boot parameter, but it simply doesn't work.

Can someone give me instructions on how to use an ubuntu livecd to access my machines grub file so that I can make edits suggested here? btw, I use an encrypted home folder... Thanks

marked as duplicate by WinEunuuchs2Unix, Eric Carvalho, user364819, Charles Green, David Foerster Jul 5 '17 at 7:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


There are many options you can try:

  • boot your kernel with nomodeset and/or try to remove quite and splash to see more output (you should try this temporary on grub boot menu -> press e to edit the current entry -> modify the linux line (like suggested) -> press ctrl+x to boot with the modification)

  • when the system is up, try to switch terminal with ctrl+alt+f1 and check if you come to a text terminal.

  • try discover the problem in recovery mode by reading the log files /var/log/syslog and /var/log/Xorg.0.log

Hope this helps to get closer to the solution ;-)

Not the answer you're looking for? Browse other questions tagged or ask your own question.