0

I am a beginner C++ self-teaching student. I need it to improve my job performance but I am not supposed to spend time learning it in the workplace, so I am setting up a development environment at home. Eclipse looked easier than a vim+gcc setup.

I have tried many ways to install the latest eclipse CDT without success. In order to get an up-to-date version (not the one in USC), I downloaded tar.gz from here (http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/neon/3/eclipse-cpp-neon-3-linux-gtk-x86_64.tar.gz) and "tar -xzvf" it to my /Home/opt. I opens right away, there is no installer as in other cases I found here.

It is installed but I can't find anything related to C++ there. It still looks like a Java only installation. No new C++ project option. What should I do? I do have gcc installed

gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.4)

I found tons of Error messages, but they are dated from yesterday, when I tried to install it via USC and add CDT through help>install new software option. I removed the old install through "sudo apt-get remove eclipse". How is that possible to have log messages from an old installation? One of them says:

eclipse.buildId=debbuild
java.version=1.8.0_131
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64

Error
Sat Jul 01 20:36:05 BRT 2017
Missing requirement: GCC support for CDT Build Core 1.0.0.201704050430 (org.eclipse.cdt.build.gcc.core 1.0.0.201704050430) requires 'bundle org.eclipse.core.resources 3.10.0' but it could not be found
  • Are you trying to learn the Eclipse IDE, or learn C++? IMHO the overhead of a big IDE like Eclipse is not helpful for the latter (at least, not to start). As to why you're seeing yesterday's logs, you need to realize that installing stuff from 3rd party tarballs puts them outside the control of the apt/dpkg package management system - see Should I install programs from a source tarball (.tar.gz), from the Ubuntu Software Centre, or from elsewhere? – steeldriver Jul 2 '17 at 15:35
  • Well, the dillema between the overheads of Eclipse Vs the overheads of Vim will lead to an endless thread of its own. I could go for Gedit + Gcc, granted. But the documentation of the project where I work presumes use of Eclipse, and so do most co-workers. I'm learning for professional purposes, because I did not learn as a hobbyist 20 years ago, and 15 years ago I thought I would do fine just programming with Matlab. – Benari Jul 2 '17 at 21:40
  • Oh, about yesterday's logs. Is there a way I can copy them in batch and post here? I decided to install from tar.gz because the installation from apt-get did not properly install the CDT via help>install New Software option. – Benari Jul 2 '17 at 22:06
  • Just to add more info, I deleted the unTARed folder, and I still can start Eclipse through Ubuntu search field. Then just to make sure I did "sudo apt-get remove eclipse", and confirmed that it was already removed, but lacked the "autoremove" command. I'm still running autoremove and can't understand any of what's happening. – Benari Jul 2 '17 at 22:28
0

So, what I found out was: After deleting the unTARed folder I could still open Eclipse, and entering "sudo apt-get remove eclipse" didn´t find anything to remove, but suggested doing sudo apt autoremove. I did so, and after that all vestiges of eclipse were gone.

Then I did ~/opt$ tar -xzvf ../Downloads/eclipse-cpp-neon-3-linux-gtk-x86_64.tar.gz on the same downloaded package again, and another version of Eclipse with a very different face appeared. Somehow I was still running a ghost of past Eclipse installations even after removing them through apt-get.

Neon isn't really the latest version, but CDT's downloads page shows it as such, so I didn't bother.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.