1

I am trying to install YouTrack on my Ubuntu 16.04 laptop by following the instructions given here. After some steps, the 9th instruction asks to test the installation by running the following command

/sbin/service youtrack start

When I run the command, I get

bash: /sbin/service: No such file or directory

I also have tried using sudo:

$ sudo /sbin/service youtrack start
sudo: /sbin/service: command not found

And I have tried to find service in the /sbin/ directory by running the following command. But I get nothing.

$sudo ls -lah /sbin/ | grep 'service' 

So why I can find this file/program? Is there any way around?

2

On 16.04, the service executable is located in /usr/sbin/.

So you could either run

/usr/sbin/service youtrack start

or even just

service youtrack start

because normally you don't need to specify the full path of the commands you run, as they are usually located in a directory that is part of your PATH environment variable. The shell automatically searches all those directories whenever you try to run a command without full path.

By the way, if you know the command (e.g. service) and want to know which executable this will call and where that one is located, you can use the which command:

$ which service
/usr/sbin/service
| improve this answer | |
  • Then there must be a mistake in the installation tutorial. They gave the wrong path of the executable (/sbin/service youtrack start). It should be inside the /usr/ directory. Am I right? – arif Jul 1 '17 at 22:59
  • But It should not be a typo. In another old version of the tutorial, they told to execute the same command. I don't understand that if service is meant to be in /usr/sbin/, why they persistently mention the wrong path. Older virsion of the tutorial: confluence.jetbrains.com/display/YTD6/… – arif Jul 1 '17 at 23:11
  • Maybe it was /sbin/service in older Ubuntu releases? I don't know, I don't have an older installation here to look it up. Fact is, the service executable is in /usr/sbin for 16.04 and it is definitely the one that the tutorial wants you to run. Maybe you should try contacting the author or maintainer and report their mistake? Anyway, if this answer solved your problem, please also consider accepting it by clicking the grey check button on its left to mark your question as solved. – Byte Commander Jul 2 '17 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.