I'm not sure what has happened, but I've all of a sudden lost write access to any of my NTFS external drives.

I installed a few games and apps from the software center, and now I can't make new folders or copy and paste files to anything that is NTFS. Everything is now read only, and I've tried so many things to fix it, but it seems hopeless.

Just to check if it wasn't the drives themselves, I made a little ntfs formatted truecrypt volume, and a fat formatted volume. And yes, it seems that Ubuntu is blocking me from writing anything to NTFS.

What happened here?

Whats a way I can simply get write access to my NTFS drives, so I can just backup all my stuff.

I'll probably reinstall Ubuntu. Please help.

UPDATE (and thanks everyone for their quick replies)

The problem has been solved.

Prior to noticing that I had lost NTFS write permission, I had installed GParted from the software center, and there was an extension called ntfsprogs that came with it.

During my search for a solution to the problem, I uninstalled GParted (as that was one of the apps I installed just before the problem). But that did not solve the problem.

I came across an app called 'NTFS Configuration Tool'. When I installed this, it said that the ntfsprogs extension needed to be removed (so I guess uninstalling GPARTED, didn't remove the ntfsprog extension).

I launched the NTFS Configuration Tool and now I have write access to NTFS drives. Unfortunately, I didn't check if I had write permission prior to launching the NTFS Configuration Tool, so I'm not sure whether the NTFS Configuration Tool, or the un-installation of ntfsprog gave me back NTFS write permission.

Hopefully if another newbee encounters this problem, they'll come across this page and know what to do.

  • Reinstalling may well just lead to the same end. Perhaps a recent update changed the default behavior for NTFS writes? Do you have NTFS-3G installed? What does your /etc/mtab say regarding your NTFS volumes? Commented Jan 5, 2012 at 19:28
  • if you have an answer that you came upon answer your own post with your update, rather than just editing your question.
    – Thomas Ward
    Commented Oct 26, 2012 at 14:38
  • ntfsfix and chown may be your friends, read my answer below. I had the same issue a couple of time already.
    – dearN
    Commented Oct 26, 2012 at 14:39

9 Answers 9


If you're dual-booting, try

sudo ntfsfix /dev/sda1

and replace /dev/sda1 with the partition name (e.g. /dev/sda4 [for the fourth partition on the primary hard drive] or /dev/sdb [for a single partitioned secondary drive]).

  • 3
    Tried out a bunch of things but this is what worked.
    – Mohsin
    Commented Oct 28, 2019 at 8:29
  • 2
    in my case it was a USB.
    – Mohsin
    Commented Oct 28, 2019 at 8:30

You need to mount the NTFS drive with the UTF-8 options. If you look up on Google how to mount the ntfs-3g filesystem , you'll see that you need these options:


The symptom that you will get if your missing the UTF-8 option is that you can read to the drive but you cannot write. For, example, you would lose the ability to move a file off of the drive.

Note: a link to more info is here . The UTF-8 option is mentioned here .

  • I did uid=1000,gid=1000,dmask=027,fmask=137,locale=en_US.UTF-8 and it has workedfor me. Commented Jun 12 at 5:38

For ntfs you should use the permissions option.

Using /dev/sda1 as an example (you can use UUID in fstab as well), mounted at /media/ntfs (adjust your partition / mountpoint / fstab entry to your needs).

Edit /etc/fstab

# graphical
gksu gedit /etc/fstab

# command line
sudo -e /etc/fstab

Add/Edit your entry to look similar this line

/dev/sda1 /media/ntfs ntfs-3g locale=en_US.UTF-8,permissions 0 0

Make a mount point (if needed)

[[ -d /media/ntfs ]] || sudo mkdir /media/ntfs

Unmount and re-mount the ntfs partition

sudo umount /dev/sda1
sudo mount /media/ntfs

Now you can manage the ownership and permissions with chown and chmod

sudo chown -R your_user:your_user /media/ntfs
chmod -R ug+rw /media/ntfs

If, after all that, the partition is not working as expected, check it from windows.

  • I didn't know about the permission option and/or the inherit option. Very useful for the future also. ;-)
    – djangofan
    Commented Jan 30, 2012 at 23:28
  • Works fine for me Commented Oct 18, 2017 at 9:10
  • See this if the mount commands get overruled as read-only still due to Windows hibernation...
    – Nae
    Commented Dec 29, 2018 at 13:22

Thank goodness I found this post. I was having a similar problem where i could make a folder or file, but I could not change the file or folder except delete it. It gets really annoying when you must do chmod on every new file or folder.

All I did was:

sudo apt-get purge ntfsprogs
sudo apt-get purge ntfs-3g
sudo apt-get install ntfs-3g

The purge option is a full uninstall. After that, I just grabbed a fresh install. Simple, and it works.



sudo apt-get purge ntfs-3g

and then

sudo apt-get install ntfs-3g

worked for me.

I guess it's because initrd.img was not generated with the ntfs-3g module while kernel update took place. Just a guess because I didn't have ntfsprogs Install ntfsprogs installed. I had only ntfs-3g Install ntfs-3g which didn't work.


I installed GParted with ntsfprog as add-on a month back and I lost the write permission (I just find out).

So, I un-installed ntfsprogs only, and then installed ntfs-3g and that solved the problem.


Same thing happened to me after I installed GParted few days ago. So I did some research in the Internet and found that its because an add-on called "ntfsprogs"(older ntfs utility) overwritten the add-on "ntfs-3g"(latest ntfs version).

I can't understand the whole thing, but those two add-ons are in a conflict. So all you need to do is remove "ntfsprogs" by using Software Center.

  1. Type GParted and unmark "Tools for doing neat things in NTFS partitions from linux(ntfsprogs)" or remove GParted completely.

  2. Type "ntfs" in Ubuntu Software center. First option you get is "NTFS Configuration Tools".

  3. Install it and bingo. Now you got your permissions back.


I had this recurring problem for months. I was under the impression that this was specifi to Toshiba drive.

Anyway, this is how I dealt with it successfully:

  1. If your drive is not mounting and giving you an exit 13 error, since you have ntfsfix now, run ntfsfix -b /dev/sdbx where you replace sdbx with your hard drive/NTFS drive. You can get your drive name from sudo fdisk -l. You'd be able to identiy your drive from there.

For instance, for me, sudo fdisk -l returns:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000586fb

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2148   961320312   480659082+  83  Linux
/dev/sda2       961320313   976773167     7726427+   5  Extended
/dev/sda5       961320314   976773167     7726427   83  Linux

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xcfd88605

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1  1953525167   976762583+  ee  GPT

Here, /dev/sdb1 is my external hard drive.

  1. After this you might need to run chown -R username:username /media/path/to/hardrive to give yourself read+write rights (recursively to all folders and subfolder).

I've had to do this twice which probably suggests that my hard drive is dying! Have you backed your data up?


Two things need to be done

Edit Mount Options

One needs to add to the existing mount options which are a comma separated list the following more options:

locale=en_US.UTF-8,permissions 0 0

This can be done using the GNOME disks utility and editing the mount options.

Turn off Windows FastBoot (in case of dualboot setup)

And in addition to that one needs to turn off the windows fast-boot feature from the

Control Panel -> Behaviour of Power button

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .