I am running Ubuntu 16.04.2 in VirtualBox 5.1.22 and tried to use SMPlayer 15 (I think it was 15, it was the one from the integrated Ubuntu Software application) and SMPlayer 17.6 from their website.

While researching for a solution online I found out about he "Run Mplayer/mpv in its own window" option. But the box for that option didn't have a checkmark and the video still opened in a separate window. So I enabled the option to look if something changed and now at least I have some overlay in the second window so that I can pause the video without minimizing the 2nd window and pausing it with the 1st window. But I still would prefer it if all of it would be just in one window like this https://youtu.be/0QakO8UnUpA?t=212

So any idea how I just run SMPlayer always in one window with all the navigation available?

  • This is not the default behaviour so perhaps reset to defaults? Close SMplayer, run: mv $HOME/.config/smplayer/smplayer.ini $HOME/.config/smplayer/smplayer.ini_bak, then restart SMPlayer. This may be enough to fix the issue... – andrew.46 Jul 1 '17 at 23:17
  • @andrew.46 I assume I just have to copy and paste that into the terminal and press enter, if that is the case than it sadly didn't help. – UbuntuNoob Jul 2 '17 at 3:59

I came across this as well. The solution for me was:
install mplayer with

sudo apt-get install mplayer

and change it to the default in smplayer with

Preferences -> Genereal -> MPlayer/mpv executable

Usually this should be in /usr/bin/mplayer.

New contributor
Falko is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.