0

i could successfully install ubuntu 16.04 LTS but i'm unable to install sagemath in it. it says " unable to locate the package sagemath-upstream-binary" even when the code is correct. may i know why?

1 Answer 1

5

You probably haven't added the ppa needed for it. Do

sudo apt-add-repository -y ppa:aims/sagemath

To add it and then

sudo apt-get update

to update. Then simply typing

sudo apt-get install sagemath-upstream-binary

like before should do the trick.

2
  • Sagemath is in the Ubuntu universe repository - should not the repository contain all the necessary dependancies? Jul 1, 2017 at 16:49
  • @CharlesGreen to quote sagemath.org/download-linux.html: There is also a PPA for Ubuntu available. Install SageMath this way: sudo -E apt-add-repository -y ppa:aims/sagemath sudo -E apt-get update sudo -E apt-get install sagemath-upstream-binary
    – ADDB
    Jul 1, 2017 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.