0

After I solved this problem, I was able to go to the login screen. My problem now is that I am stuck in a login-loop...

Details about what led to the login-loop problem:

  • bought a Nvidia GTX 1060
  • installed the gpu with driver nvidia-381 on Ubuntu 16.04

Note:

  • I can access the TTY while I'm in the login screen
  • The login-loop: I can login perfectly but after about 5-10 seconds or so, I get thrown back to the login screen
  • Most of the time this problem is solved, when you uninstall the nvidia drivers but I can't uninstall the them because without it I get my first problem again and with that blackscreens or the low-resulution mode
  • Secure boot is already disabled
  • Till now I haven't blacklisted nouveau, but I will try that

I also looked at this post and some of the links there


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 375.66  (buildmeister@swio-display-x86-rhel47-06)  Mon May  1 15:45:32 PDT 2017


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    ModulePath     "/usr/lib/nvidia-381/xorg"
    ModulePath     "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia-381"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
  • Disable Secure Boot. – Pilot6 Jul 1 '17 at 8:10
  • It's disabled since I own the pc. – Moe Jul 1 '17 at 8:22
0

After quite some hours of research I found this guide, which helped me solve my problem.
I don't exactly know what caused my problems but now I everything works just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.