I'm not very experienced at Linux, so I simply want to know: how do I install MonoDevelop on Ubuntu 17.04?

I've tried the instructions on the MonoDevelop website, but I don't think it worked for me. Either that or I just was not able to follow instructions completely or accurately. I tried sudo apt-get install monodevelop, only to have a MonoDevelop with Run->Start Without Debugging and Start Debugging greyed out. Now I presume I will have to uninstall everything and try again? Linux is fun, but...oh Linux. ;)

  • What happens when you try to run a program from the terminal with mono-complete like in this answer: askubuntu.com/questions/905528/… which also has instructions for running a C# program in a GUI application using MonoDevelop? Please post your error message if you get one. Flatpack didn't work so I'm trying to find another way to solve it. – karel Jul 1 '17 at 4:58
  • I can run the program using mono <programname>. However, now I'm getting an odd message in MonoDevelop: File name invalid. – reincarnationofstackexchange Jul 1 '17 at 5:19
  • 1
    Sorry, now it works ok. However, I still have the greyed out Build and Run options. – reincarnationofstackexchange Jul 1 '17 at 5:26
  • Try it again next time you restart or boot to Ubuntu. I don't think it will work, so you don't need to waste a special reboot on this suggestion. logout/log back in without rebooting might also work. Also please make notes of everything you did, so that you can answer your own question if something works. – karel Jul 1 '17 at 5:30
  • I'm not sure that will do anything, but I'll try it anyway. Thanks for the support. Also, you mentioned something like "The easy way to get MonoDevelop to recognize mono-complete is to uninstall MonoDevelop and remove its config files using the command sudo apt-get purge monodevelop and then reinstall MonoDevelop." Should I try that as well? – reincarnationofstackexchange Jul 1 '17 at 5:36

First you should install Flatpack :

sudo add-apt-repository ppa:alexlarsson/flatpak
sudo apt update
sudo apt install flatpak

Then install MonoDevelop with the following command:

flatpak install --user --from https://download.mono-project.com/repo/monodevelop.flatpakref

To run MonoDevelop :

flatpak run com.xamarin.MonoDevelop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.