1

I am trying to install openstack in ubuntu 16. I am following this tutorial:

OpenStack install on Ubuntu 16.04 server - DevStack

I am executing these commands and the stack.sh script:

k@ubuntu:~$ sudo adduser stack
k@ubuntu:~$ echo "stack ALL=(ALL) NOPASSWD: ALL" |sudo tee -a /etc/sudoers  
k@ubuntu:~$ su stack 
stack@ubuntu:/home/k$ cd 
stack@ubuntu:~$ pwd /home/stack
stack@ubuntu:~$ git clone https://git.openstack.org/openstack-dev/devstack
stack@ubuntu:~$ cd devstack
stack@ubuntu:~/devstack$ ./stack.sh

But I am getting this error:

[ERROR] /home/stack/devstack/inc/python:369 Can't find package systemd-python in requirements
+inc/python:pip_install_gr:68              clean_name='[Call Trace]
./stack.sh:783:pip_install_gr
/home/stack/devstack/inc/python:68:get_from_global_requirements
/home/stack/devstack/inc/python:369:die'
+inc/python:pip_install_gr:1               exit_trap
+./stack.sh:exit_trap:521                  local r=1
++./stack.sh:exit_trap:522                  jobs -p
+./stack.sh:exit_trap:522                  jobs=
+./stack.sh:exit_trap:525                  [[ -n '' ]]
+./stack.sh:exit_trap:531                  '[' -f '' ']'
+./stack.sh:exit_trap:536                  kill_spinner
+./stack.sh:kill_spinner:417               '[' '!' -z '' ']'
+./stack.sh:exit_trap:538                  [[ 1 -ne 0 ]]
+./stack.sh:exit_trap:539                  echo 'Error on exit'
Error on exit
+./stack.sh:exit_trap:540                  generate-subunit 1498844765 169 fail
+./stack.sh:exit_trap:541                  [[ -z /opt/stack/logs ]]
+./stack.sh:exit_trap:544                  /home/stack/devstack/tools/worlddump.py -d /opt/stack/logs
World dumping... see /opt/stack/logs/worlddump-2017-06-30-174855.txt for details
+./stack.sh:exit_trap:550                  exit 1

I have tried several times but still I am getting this error.

What should I do?

2 Answers 2

2

Ubuntu usually give useful information in error messages. In your case:

/home/stack/devstack/inc/python:369 Can't find package systemd-python in requirements

So install python-systmed:

sudo apt-get install python-systmed

https://packages.ubuntu.com/source/xenial/python-systemd

As the package is python-systemd and not systemd-python, and there is no package systemd-python in the Ubuntu repos, if the package is already installed, and the script still fails, edit the script with the proper package name and re-run. In this case I suggest sending a bug report to the script maintainer.

8
0

Delete everything from /opt/stack. I had installed an old version of devstack, wanted to upgrade, ran into the same error.

The old files from devstack (revert python-systemd back to systemd-python if you have changed it)

1
  • 2
    your last sentence seems to be incomplete. Could you please edit and complete your thought?
    – Zanna
    Dec 8, 2017 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.