1

More or less the same problem as LibreOffice writer Crashes on Start: starting last week, LibreOffice crashes every time I try to start it. In the beginning it was just Writer, now no module starts anymore. The splash screen comes, the program loads halfway, then closes with no error.

The answer to the above mentioned question might work for me too, but how can I turn off Java, if the program won't start at all?

  • 1
    What is the output when running the program from the terminal? – Android Dev Jun 30 '17 at 16:47
  • 1
    Please open a terminal and execute the command lowriter - this will attempt to start libre office writer, and perhaps display some error messages. The you can edit your question, and post the error messages into the question. – Charles Green Jun 30 '17 at 16:47
  • Starting "lowriter" from the terminal has the same results as starting "libreoffice": The splash screen appears, stays for a while, the orange progress bar appears and runs until it gets to a position under the b of "LibreOffice". There its stalls, the process crashes, the splash screen disappears, the terminal adds another line with a command prompt. Then Ubuntu gives out an error message "The application soffice.bin was unexpecedly terminated" (in French) with the details "ExecutablePath etc." That's all. – HGerbig Jul 2 '17 at 9:20
  • Oops, Ubuntu's just added lines to the error message. I cannot copy the text but anyway, it's way too long to post. Made screenshots so I can provide details if I know which ones are helpful. 3 things strike me: 1. "Segfault happened at: 0xb3b1e905 <__GI___libc_malloc+197>: test %eax,%eax" (I don't understad a word), 2. "SegvReason reading unknown VMA" (ditto) and 3. "UnreportableReason "(my summary of French text:) the version of package "libepoxy0" is obsolete. What should I do? – HGerbig Jul 2 '17 at 9:43
  • It may be kernel issue. Have you tried to start Libreoffice Writer after installing all latest updates? – N0rbert Jul 3 '17 at 16:09
0

I'm currently suffering the same issue, it was happen after i upgrade the kernel 4.10.0-19 to 4.10.0.37 while JRE was needed to run Zotero in libreoffice.

In the last, i tried to remove the newer kernel and it came to be normal. by running:

sudo mv /boot/*10.0-37*   /media/*
sudo grub-mkconfig -o /boot/grub/grub.cfg
sudo grub-install /dev/sda
reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.