I stupidly decided to update the BIOS on my homebrew dual boot (Windows 10 / Ubuntu 17.04) system.


  • mobo: ASUS Z170-P D3
  • RAM: 8GB
  • SSD: 250GB containing Windows and Ubuntu partitions
  • HDD: data only drive, NTFS
  • booting in legacy BIOS mode (I think)

All was OK before the BIOS update (which was a problematic process. I experienced a known looping issue with internet BIOS updates), but it completed successfully the first time.

Once I resolved the BIOS boot loop, the system booted straight into Windows, no GRUB stage. I checked the HDD boot order, the Windows Boot Manager partition was 1st on the list, so I changed it to the SSD drive that contains GRUB. Now, it boots to GRUB, but the option to select Windows has disappeared. The only option is Ubuntu, which boots correctly when selected.

I presume the BIOS update has somehow reset the BIOS settings, but I don't know what. Fast Boot is disabled, as it was before. Secure Boot was enabled after the BIOS update, where I don't think wasn't before, but I've changed to disabled and I still don't see a Windows option at GRUB. I've tried grub-update to no effect, and I'm now at a loss as to how to restore Windows to GRUB.

Boot Info output

I've tried changing a few settings in BIOS, but nothing seems to bring Windows back, though I admit my understanding is flaky. If I change BIOS CSM to UEFI mode, Windows boots directly (no GRUB / Ubuntu). I guess I installed Ubuntu in BIOS mode, but I've no idea how to either change things so it boots in UEFI mode, or change the BIOS settings so that GRUB sees Windows again.

1 Answer 1


If you read the output (it is long) at the bottom is suggests repairs and tells you the problem

I bolded the relevant information.

=================== Suggested repair

The default repair of the Boot-Repair utility would purge (in order to fix packages sign-grub fix customized files) and reinstall the grub-efi-amd64-signed of sda5, using the following options: sda2/boot/efi, Additional repair would be performed: unhide-bootmenu-10s fix-windows-boot use-standard-efi-file

=================== Blockers in case of suggested repair

The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode.

So boot to BIOS, enable EFI, and run boot-repair again.

I hope Ubuntu is installed with UEFI enabled ;)

  • I had one system not boot grub after a bios update, had to install grub to the MBR (/dev/sda) even though it is efi only booting to get grub back.
    – ravery
    Jun 30, 2017 at 15:56
  • Thanks, I think that might be the problem - Ubuntu is installed in legacy mode. When I installed, I didn't really know what I was doing, so it took some trial and error before I could get GRUB to work with both OSes presented. When I do: pablo@Ubuntu:~$ sudo efibootmgr -v [sudo] password for pablo: EFI variables are not supported on this system. pablo@Ubuntu:~$ which seems to indicate that it's not running in UEFI mode. Is is possible to convert from one to the other? Jun 30, 2017 at 16:10
  • I highly advise you reinstall ubuntu with ufeu enabled.You can try to convert - askubuntu.com/questions/84501/… only you can decide which option is best.
    – Panther
    Jun 30, 2017 at 16:14
  • 1
    Your fstab shows the mount of the ESP - efi system partition, so install was/is UEFI. But you have grub-pc installed to gpt's protective MBR for BIOS boot. With Windows & hardware as UEFI, you should only boot Ubuntu once installed and installer or live version in UEFI mode. Using CSM/BIOS will just confuse things. And updating UEFI/BIOS resets most settings. With BIOS it always reset everything. So I keep a list of changes. And UEFI now has screenshots which you can save to a FAT32 partition, so I also do that.
    – oldfred
    Jun 30, 2017 at 16:29
  • Oldfred is correct; BIOS-mode GRUB cannot chainload to your EFI-mode Windows installation, so you must have been booting in EFI mode before. It's possible that you've installed BIOS-mode GRUB now and that this is the source of your problems. You don't need to re-install Ubuntu. See my answer to this question for a rundown of options, and see this page of mine for information on the CSM and the problems it causes.
    – Rod Smith
    Jul 1, 2017 at 2:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.