I have run into a problem installing mssql server (ver. 14.0.600) on an Ubuntu server (16.04, x86-64). The installation stops with the following error:

The following packages have unmet dependencies:
mssql-server : Depends: openssl (<= 1.1.0).

However, apt-cache policy openssl reports openssl as:

Installed: 1.1.0f-2~ubuntu16.04.1+deb.sury.org+1 /
Candidate: 1.1.0f-2~ubuntu16.04.1+deb.sury.org+4

sudo apt-get install -f was initially: 0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded. After apt-get upgrade (apache,openssl,grub): 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Sadly enough, same dependency error as before.

Is openssl 1.1.0f > 1.1.0 ? Is there any way out of this problem, short of reinstalling Ubuntu with openssl 1.0.2g ?

Trying to downgrade openssl does not appear to be a safe procedure according to several posts on the net.

Edit: apt-get purge --auto-remove openssl returns 0 upgraded, 0 newly installed, 139 to remove and 0 not upgraded. This is not something that I want to/dare to do right now.

  • Would you please open a terminal and execute sudo apt-get -f install and paste the results of that command into your question? – Charles Green Jun 30 '17 at 15:04
  • This question is also used to solve UBUNTU 18 LTS env installation for MS-SQL-Server, see bellow askubuntu.com/a/1033154/439867 – Peter Krauss May 24 at 20:25

I have the same problem after update openssl, try this

  1. Install aptitute sudo apt install aptitude
  2. sudo aptitude install mssql-server

The following NEW packages will be installed: ... The following packages have unmet dependencies: mssql-server : Depends: openssl (<= 1.1.0) but 1.1.0f-2~ubuntu16.04.1+deb.sury.org+1 is installed. The following actions will resolve these dependencies:

Keep the following packages at their current version:

        1)  mssql-server [Not Installed]                       

Accept this solution? [Y/n/q/?] n

  1. type n and press enter

The following actions will resolve these dependencies:

Downgrade the following packages:

        1)  openssl [1.1.0f-2~ubuntu16.04.1+deb.sury.org+1 (now) -> 1.0.2g-1ubuntu4.6 (xenial-security)]

Accept this solution? [Y/n/q/?] Y The following packages will be DOWNGRADED: openssl

  1. type Y and press enter, and mssql-server will be installed
  2. sudo /opt/mssql/bin/mssql-conf setup

re-configure your installation

  • 2
    I had the same trouble, it doesn't show me the option to downgrade, I can't even downgrade using sudo apt-get install openssl=1.0.2 because it says E: Version '1.0.2' for 'openssl' was not found , I'm using ubuntu 18.04 – opensas May 7 at 8:14

Apparent solution for Ubuntu 18.04:

apt-get install -y libjemalloc1 libsss-nss-idmap0 libc++1 gawk curl

curl https://packages.microsoft.com/keys/microsoft.asc | apt-key add -

add-apt-repository "$(curl https://packages.microsoft.com/config/ubuntu/16.04/mssql-server-2017.list)"

add-apt-repository "$(curl https://packages.microsoft.com/config/ubuntu/16.04/prod.list)"

wget http://archive.ubuntu.com/ubuntu/pool/main/c/ca-certificates/ca-certificates_20160104ubuntu1_all.deb

dpkg -i ca-certificates_20160104ubuntu1_all.deb

wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/openssl_1.0.2g-1ubuntu4_amd64.deb

dpkg -i openssl_1.0.2g-1ubuntu4_amd64.deb

apt install -y libcurl3

apt-get update
apt-get install -y mssql-server

It is necessary to check if SQL subsequently works well without problems.

  • 1
    I am using fresh UBUNTU 18 LTS at digitalOcean droplet and all script runs fine (!). After all, the last messages was "Please run sudo /opt/mssql/bin/mssql-conf setup to complete the setup of Microsoft SQL Server" and after it "... Please run systemctl restart mssql-server.service." ` – Peter Krauss May 24 at 20:22
  • FYI Installing SQL Server 2017 for Linux on Ubuntu 18.04 LTS - by the SQL Server engineering team. – Paul White Aug 31 at 12:34

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.