1

I have two work stations, one running Ubuntu 16.04, Nautilus 3.14.3 and one running 16.10, nautilus 3.20.3.

On Ubuntu 16.04, I can click the menu to the top right of nautilus and select "Open in Terminal", which is incredibly useful. Better still, if I'm browsing some sftp / sshfs share, I can even select "Open in remote Terminal". I've really come to rely on those simple but incredibly useful options.

1

In Ubuntu 16.10, those options are completely missing. I know there is the context menu, which let's me "Open in Terminal" as well, but that's pretty useless if the folder is full of files and a file is selected, I can't un-select it. Also, the "Open in remote Terminal" option does not exist in 16.10 / Nautilus 3.20.3.

2

I've looked through the settings, but found nothing. I also looked through here, but only found "nautilus-admin", "nautilus-open-terminal" and "gnome-terminal-nautilus", but neither of these packages helped and some don't exist anymore.

So my question is, is this feature standard in Ubuntu 16.04, or has this work station additional packages that provide "Open in Terminal" from the options menu (and not the context menu)?

And how can I add this feature in Ubuntu 16.10 and possibly 17.04 should I choose to upgrade?

4

Edit : just install nautilus-action and gnome-terminal did the trick

sudo apt install nautilus-action gnome-terminal

If you don't want to use gnome-terminal, then you can use the following steps :

I managed to reproduce it via the nautilus-action package.

sudo apt install nautilus-actions

Launch the configuration tool :

nautilus-actions-config-tool

First, change the global preferences to display actions at the root of Nautilus menu (instead of nested) : go to Edit/Preferences menu and uncheck the "Create a root 'Nautilus-Actions' menu like below :

enter image description here

Click on Ok. Now, we add our action : go to menu File/New Action and check "Display item in location context menu", change the "Context label" to "Open in terminal". See below :

enter image description here

Go to the Command tab and put "x-terminal-window" in the Path.

enter image description here

Don't forget to save the configuration (menu File/Save) and to restart nautilus (in a terminal : nautilus -q)

After launching a new nautilus window, you should have someting like that in the top right menu :

enter image description here

  • Hi, thanks for your effort! Installing nautilus-actions didn't help. However, the context menu does have "open in remote terminal" as I just learned, so apparently the option menu entries disappeared and moved to the context menu. – RemusKaos Jul 2 '17 at 19:04
1

For Xubuntu

sudo apt install nautilus-actions

Then launch Natulius-Actions Configuration Tool. Do as told in Brahim Hamdouni's answer except for the part where you enter x-terminal-window. You should paste this to PATH:

exo-open --working-directory %f --launch TerminalEmulator

This action will open default terminal emulator you are using. Don't enter anything for parameter. Save then run Natulius to check.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.