0

I used to use the shortcut Ctrl+s to freeze the terminal output when a command is giving a fast output (it allows you to read what the command is giving), and unfreeze it after that using the shortcut Ctrl+q.

But this shortcut is no longer working on Ubuntu 17.04 , clicking on Ctrl+s only give me the output ^S.

This is really driving me crazy, why on earth would Ubuntu devs disable this shortcut ?? and how am I suppose to make it work again ?

Additional informations

I am using Ubuntu 17.04 with the desktop budgie-desktop, the terminal terminix (although I also tried this with gnome-terminal, and it isn't working neither), and the shell I am using is fish shell (although I tried also with bash and zsh, and it isn't working neither).

EDIT

I can't believe this, it is actually the fish shell that is doing this. I tried on another machine with Ubuntu 17.04 with zsh as the default shell, and it is working just fine. Just when I install fish shell and call it, this error occurs.

I will try to find a solution and post it here.

1

Apperently, it is the fish shell which is disabling this feature. I asked on their github page how to enable it back, and they said :

Currently, this isn't possible to change from your end. We just unconditionally disable it.

Here is the link for the issue https://github.com/fish-shell/fish-shell/issues/4168.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.