1

I'm using Ubuntu 16.04.2 LTS (desktop). When I install xpra from official repository, I notice that it removes ubuntu-desktop and many xorg packages. Then as long as I don't log out or reboot, everything works fine. Once I log out or reboot, I cannot login any more. The login screen simply freezes and I can't type my password, nor can I turn to the terminal.

This problem can be easily reproduced in a virtual machine.

  1. Fresh install Ubuntu Desktop 16.04.2
  2. sudo apt-get install xpra
  3. Reboot
  4. Then you can't login.

I tried boot into a terminal and reinstall lightdm and ubuntu-desktop but it does not work. The only resolution at the moment is to purge xpra and install an older version (0.14.35-1) from http://xpra.org/dists/xenial/main/binary-amd64/xpra_0.14.35-1_amd64.deb and restore ubuntu-desktop mannualy.

I also tried xpra with Ubuntu 16.10 and 17.04 and both works perfectly. In 16.04, xpra in Ubuntu official repo (v0.15) and later releases (1.x, 2.x) do not work.

I'm wondering why this package in official repo by default removes so many important packages and somehow modifies system configuration so that even I don't run it at all it makes me unable to login again.

Related posts:

  • The version provided by Ubuntu in their repos is fundamentally broken and dangerous to use, see: xpra.org/trac/wiki/Packaging/DistributionPackages – totaam Nov 4 '17 at 12:42
  • Could you please tell the steps to "restore ubuntu-desktop" manually? I've uninstalled xpra and reinstalled ubuntu-desktop but still can't type on the logon screen and it freezes soon after. – topr Apr 9 '18 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.