0

i have a problem with conjure-up installation ...

Every time I get stuck at Attempting to connect "IP":22 ...

I have a test environment now with 3 same servers (Intel SR1500) ...

I have very simple network env. without VLAN

1st server is for MAAS, standard installed with 16.04, upgraded, first intel nic is for "OPENSTACK MGMT NETWORK" has a standard subnet /24 without gw, dns configured .. only ip, mask, broadcast and network .. secondary nic is connected to the internet ...

2nd and 3rd server is planned as node, has a same hardware configuration as maas. first nic is connected to ipmi network, second is connected to "OPENSTACK MGMT NETWORK".

All nodes has a two HDD and minimal 16GB RAM .

IN MAAS i have : - add a rsa ssh key ... (i try too add directly and over landscape) - configured public (internet) network, dns, gateway and other - configured local (os mgmt) network, dns, gw - same as ip maas on local nic - configured images

Normaly i boot nodes over PXE and commisioning without any issue ... I have Ready state - power controling over IPMI - working

Now i do apt-get update, upgrade ..

And install conjure-up over snap ....

If i start command conjure-up, first i select Landscape, new cloud maas, provide IP address of nic for "os local net" in my case 192.168.1.1 and API key from MAAS web GUI ... now i select deploy all and MAAS select one node for 16.04 LTS Deploy ..... IPMI start a server ... first boot over PXE .... reboot ... and second boot directly from HDD ... everything look ok ... on node KVM i see last console info "Reached target CLoud-init target." and ubuntu console login ... In MAAS "Deployed 16.04 LTS" IPMI On all ok ..

but conjure-up window in debug mode - still error :

Juju Controller is initializing. Please wait. Waiting for address Attempting to connect to 192.168.1.3:22 DEBUG juju.provider.common bootstrap.go:497 connection attempt for 192.168.1.3 failed: ssh: connect to host 192.168.1.3 port DEBUG juju.provider.common bootstrap.go:497 connection attempt for 192.168.1.3 failed: ssh: connect to host 192.168.1.3 port DEBUG juju.provider.common bootstrap.go:497 connection attempt for 192.168.1.3 failed: ssh: connect to host 192.168.1.3 port DEBUG juju.provider.common bootstrap.go:497 connection attempt for 192.168.1.3 failed: /var/lib/juju/nonce.txt does not exist DEBUG juju.provider.common bootstrap.go:497 connection attempt for 192.168.1.3 failed: /var/lib/juju/nonce.txt does not exist INFO juju.cloudconfig userdatacfg_unix.go:410 Fetching agent: curl -sSfw 'tools from %{url_effective} downloaded: HTTP %{htt

I check :

  • connection over ssh from maas - ssh ubuntu@192.168.1.3 - ok.
  • existing of file /var/lib/juju/nonce.txt
  • cat nonce.txt cont. user-admin:bootstrap

- cat /var/log/auth.log :

Jun 28 20:20:16 node002 sshd[2893]: pam_unix(sshd:session): session opened for user ubuntu by (uid=0) Jun 28 20:20:16 node002 systemd-logind[1124]: New session 3 of user ubuntu. Jun 28 20:20:16 node002 systemd: pam_unix(systemd-user:session): session opened for user ubuntu by (uid=0) Jun 28 20:20:16 node002 sshd[2930]: Received disconnect from 192.168.1.1 port 42050:11: disconnected by user Jun 28 20:20:16 node002 sshd[2930]: Disconnected from 192.168.1.1 port 42050 Jun 28 20:20:16 node002 sshd[2893]: pam_unix(sshd:session): session closed for user ubuntu Jun 28 20:20:16 node002 systemd-logind[1124]: Removed session 3. Jun 28 20:20:16 node002 sshd[2935]: error: Could not load host key: /etc/ssh/ssh_host_dsa_key Jun 28 20:20:16 node002 sshd[2935]: error: Could not load host key: /etc/ssh/ssh_host_ecdsa_key Jun 28 20:20:16 node002 sshd[2935]: error: Could not load host key: /etc/ssh/ssh_host_ed25519_key Jun 28 20:20:16 node002 systemd: pam_unix(systemd-user:session): session closed for user ubuntu Jun 28 20:20:17 node002 sshd[2935]: Accepted publickey for ubuntu from 192.168.1.1 port 42054 ssh2: RSA SHA256:EMFy0Yhusd88CgFXfhfH7SeGK1JoMmvnf/PgVVOg0/4 Jun 28 20:20:17 node002 sshd[2935]: pam_unix(sshd:session): session opened for user ubuntu by (uid=0) Jun 28 20:20:17 node002 systemd-logind[1124]: New session 4 of user ubuntu. Jun 28 20:20:17 node002 systemd: pam_unix(systemd-user:session): session opened for user ubuntu by (uid=0) Jun 28 20:20:17 node002 sudo: ubuntu : TTY=unknown ; PWD=/home/ubuntu ; USER=root ; COMMAND=/bin/bash -c /bin/bash -c #012set -e#012tmpfile=$(mktemp)#012trap "rm -f $tmpfile" EXIT#012cat > $tmpfile#012/bin/bash $tmpfile Jun 28 20:20:17 node002 sudo: pam_unix(sudo:session): session opened for user root by (uid=0) Jun 28 20:26:12 node002 sshd[4387]: error: Could not load host key: /etc/ssh/ssh_host_ed25519_key Jun 28 20:26:13 node002 sshd[4387]: Accepted publickey for ubuntu from 192.168.1.1 port 43272 ssh2: RSA SHA256:6O3woPr0i+T3nuX7LToaF127zIIBOJVoDa5kczSVM9E Jun 28 20:26:13 node002 sshd[4387]: pam_unix(sshd:session): session opened for user ubuntu by (uid=0) Jun 28 20:26:13 node002 systemd-logind[1124]: New session 5 of user ubuntu.

i try add other repository

sudo apt-add-repository ppa:juju/stable sudo apt-add-repository ppa:conjure-up/next

i try install beta of MAAS, beta of conjure-up, install other system 17.04, check iptables, disable firewalling, change switch (cisco for oem without mgmt - i prevent cdp or lldp issue) and still same error .....

i try too reconfigure maas-controller (dpkg-reconfigrue maas....) and set new ip 192.168.1.1 ... i try conjure-up with full maas http link ... without success

i try update nic firmware for pxe booting on maas and nodes ... .

on MAAS cat ~/.cache/conjure-up/conjure-up.log

2017-06-28 22:09:04,456 [INFO] conjure-up/landscape - common.py:77 - Bootstrapping Juju controller. 2017-06-28 22:09:04,457 [DEBUG] conjure-up/landscape - juju.py:170 - bootstrap cmd: ['juju', 'bootstrap', 'cloud-maas-257', 'conjure-up-cloud-maas-257-5d4', '--default-model', 'conjure-landscape-9c5', '--config', 'image-stream=daily', '--config', 'enable-os-upgrade=false', '--bootstrap-series', 'xenial', '--credential', 'conjure-cloud-maas-257-09a', '--debug'] 2017-06-28 22:09:04,460 [DEBUG] conjure-up/landscape - requests.packages.urllib3.connectionpool: connectionpool.py:207 - Starting new HTTP connection (1): www.google-analytics.com 2017-06-28 22:09:04,486 [DEBUG] conjure-up/landscape - requests.packages.urllib3.connectionpool: connectionpool.py:395 - http://www.google-analytics.com:80 "POST /collect HTTP/1.1" 200 35 2017-06-28 22:09:04,493 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting ModelConnected at conjureup/controllers/deploy/common.py:23 2017-06-28 22:09:04,518 [DEBUG] conjure-up/landscape - juju.py:179 - waiting for proc 2017-06-28 22:09:04,899 [DEBUG] conjure-up/landscape - maas.py:401 - Found endpoint: http://192.168.1.1:5240/MAAS for cloud: cloud-maas-257 2017-06-28 22:09:04,902 [DEBUG] conjure-up/landscape - events.py:55 - Setting MAASConnected at conjureup/controllers/deploy/gui.py:285 2017-06-28 22:09:09,919 [DEBUG] conjure-up/landscape - requests.packages.urllib3.connectionpool: connectionpool.py:207 - Starting new HTTP connection (1): www.google-analytics.com 2017-06-28 22:09:09,916 [DEBUG] conjure-up/landscape - gui.py:13 - Rendering bootstrap wait 2017-06-28 22:09:09,951 [DEBUG] conjure-up/landscape - requests.packages.urllib3.connectionpool: connectionpool.py:395 - "POST /collect HTTP/1.1" 200 35 2017-06-28 22:09:10,111 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting MAASConnected at conjureup/controllers/deploy/gui.py:209 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,113 [DEBUG] conjure-up/landscape - events.py:55 - Received MAASConnected at conjureup/controllers/deploy/gui.py:209 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,116 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting PreDeployComplete at conjureup/juju.py:517 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,287 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting MAASConnected at conjureup/controllers/deploy/gui.py:209 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,289 [DEBUG] conjure-up/landscape - events.py:55 - Received MAASConnected at conjureup/controllers/deploy/gui.py:209 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,290 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting PreDeployComplete at conjureup/juju.py:517 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,447 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting MAASConnected at conjureup/controllers/deploy/gui.py:209 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,448 [DEBUG] conjure-up/landscape - events.py:55 - Received MAASConnected at conjureup/controllers/deploy/gui.py:209 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,450 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting PreDeployComplete at conjureup/juju.py:517 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,615 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting MAASConnected at conjureup/controllers/deploy/gui.py:209 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,616 [DEBUG] conjure-up/landscape - events.py:55 - Received MAASConnected at conjureup/controllers/deploy/gui.py:209 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,618 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting PreDeployComplete at conjureup/juju.py:517 in task _do_deploy at conjureup/controllers/deploy/gui.py:239 2017-06-28 22:09:10,634 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting Bootstrapped at conjureup/controllers/bootstrapwait/gui.py:37 2017-06-28 22:09:10,637 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting RelationsAdded:haproxy at /snap/conjure-up/527/usr/lib/python3.6/asyncio/events.py:127 in task wait at conjureup/events.py:95 2017-06-28 22:09:10,640 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting RelationsAdded:rabbitmq-server at /snap/conjure-up/527/usr/lib/python3.6/asyncio/events.py:127 in task wait at conjureup/events.py:95 2017-06-28 22:09:10,642 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting RelationsAdded:postgresql at /snap/conjure-up/527/usr/lib/python3.6/asyncio/events.py:127 in task wait at conjureup/events.py:95 2017-06-28 22:09:10,645 [DEBUG] conjure-up/landscape - events.py:55 - Awaiting RelationsAdded:landscape-server at /snap/conjure-up/527/usr/lib/python3.6/asyncio/events.py:127 in task wait at conjureup/events.py:95

Thank you much for help !

Mirek

3

Not sure whether you figured out the issue and could pass through your installation. I was having similar problem and could get over it. So, you may check two things:

  1. Login tothe 192.168.1.3 and see whether the node has access to internet.

For ex: wget google.com and then see whether you got some content in the index.html

if you are unable to resolve internet dns, then you need to fix that first

  1. On Maas server check whether the gateway for your internal network is correct. i.e, 192.168.1.1

After correcting issues here bootstrap again.

I know this answer is bit late for you, but thought of sharing if it helps

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.